Unable to connect


I have a device that ran perfectly for about half a year, but suddenly stopped working a few months ago. Now I came around to try and fix it. I don’t know of any changes in the network, or otherwise, around that time, which could have caused it.

The Particle Photon in question cannot connect to the cloud. I tried reading through all relevant threads I could find, running the device doctor, upgrading, trying all kinds of things with the local WIFI, tried both internal and external antenna, etc. But no success. It just won’t connect. It just blinks rapid green now.

What can I do to solve this? Any help appreciated :slight_smile:

Rapid blinking green is when the Photon is trying to get an IP address from the network DHCP server. That could have been something that changed that would affect a previously working Photon.

Getting a log using the Photon cloud debug tool may be helpful in figuring out what’s actually going wrong.


As a way to rule out the network, could you try it on a different network, or with a hotspot?

Tried it with an iPhone hotspot, and this actually gives a slightly different result:

blinking cyan -> rapidly blinking cyan (burst) -> short orange light.

Unfortunately that doesn’t tell me much :slight_smile:

It is possible that you have corrupted device keys. You’ll need to have the Particle Command Line Interface (CLI) installed, so if you have not installed it yet, follow the instructions here:


Put the Photon into Listening mode (blinking blue) by holding down SETUP until it blinks blue. Then issue the CLI command:

particle serial identify

Save the Device ID; you’ll need it later.

Then put the Photon in DFU mode by holding down both the RESET and SETUP buttons, releasing RESET and continuing to hold down SETUP until it blinks yellow and issue the commands below, in order.

particle keys server
particle keys doctor YOUR_DEVICE_ID

If you get this error under Windows:

'openssl' is not recognized as an internal or external command, operable program or batch file.

and you have used the CLI installer as described above, it may work if you do:

cd c:\OpenSSL-Win32\bin
particle keys doctor YOUR_DEVICE_ID

There are additional tips for a missing openssl error on this page, including tips for Mac OS X and Linux.

I have the Particle CLI and ran through the device doctor, which I believe did reset the keys. So that should have been properly tested like that?

photon-clouddebug output:

configured credentials:
ssid=<wifi_ssid> security=not set cipher=1
ssid=Dennis's iPhone security=wpa2 cipher=1
ssid=<wifi_ssid> security=not set cipher=1
ssid= security=not set cipher=1et cipher=1
available access points:
SSID=<wifi_ssid> security=unsecured channel=6 rssi=-61
SSID= security=wpa2 channel=6 rssi=-61
SSID=<wifi_ssid> security=unsecured channel=6 rssi=-45
SSID= security=wpa2 channel=6 rssi=-45
connecting to WiFi

It just hangs there.

Hmm… maybe try clearing the credentials: hold down the SETUP button until the LED blinks dark blue, and continue holding it down until it blinks dark blue rapidly, then release.

Connect the Photon to your computer by USB and configure the Wi-Fi again:

particle serial wifi

Thanks for helping out!

I tried that: no change.

I believe the credentials were also cleared as part of the device doctor.

I almost think some hardware has gone bad, since it just keeps refusing to connect to wifi, after having worked fine for several months…

In that case, create a support ticket and reference this post.

Yeah, I will do that. Thanks again :slight_smile: