Photon (bought in 2016) cannot connect to cloud

Thanks, will DM you in a sec.

It looks like five keys have been uploaded, but never used.

You do not have any cloud connections that failed because the device private key sent by the device didn’t match the device public key.

This means that it’s most likely one of:

  • The cloud public key or server address is invalid. This should have been fixed by particle keys server however.
  • A problem with DNS
  • A firewall blocking the TCP cloud connection
  • A captive portal intercepting the connection

If you can can test using a phone hotspot, that would be a good test to see if the device can connect. Set up your phone hotspot and use the particle serial wifi Particle CLI command to set the Wi-Fi credentials with the Photon connected by USB to your computer. You can’t use the Particle mobile app to configure Wi-Fi for the hotspot running on the same phone.

Hi Rick, thanks for checking.

Someone suggested trying with a phone hotspot and I tried a couple of weeks ago, getting the same error. Basically, I’ve tried using my home router and phone.

The cloud connection error I’m getting has a Handshake failed: 26 error, which seems to relate to an IO_ERROR_LIGHTSSL_HANDSHAKE_RECV_KEY error (see a few posts above). I’ve run particle keys server a few times, that’s probably why there are 5 unused keys.

I’m out of ideas :slight_smile:

Did you clear credentials by holding down SETUP until the status LED blinks dark blue, then keep holding it down until it blinks dark blue rapidly?

Since your home Wi-Fi is still accessible, the Photon will probably still connect to it, even though you’ve also configured your hotspot Wi-Fi.

In any case, something is preventing your Photon from even attempting to authenticate with the Particle cloud, as there are no connection attempts logged on the cloud side.

1 Like

I’ve tried again, clearing all credentials and using two different phones. I can see the Photon connects to the phones as they list the device in their hotspot menus. Alas, I’m getting the same behaviour: cyan blinking + 3 orange blinks, and then cyan blinking + red blink.

I’ve tried running the device doctor again and I’m getting a slightly different error message:

0000071296 [system] INFO: Cloud socket connected
0000071296 [comm.protocol.handshake] INFO: Establish secure connection
0000071659 [comm.protocol.handshake] ERROR: Handshake failed: 6
0000071747 [system] WARN: Internet available, cloud not reachable
0000071747 [system] WARN: Cloud handshake failed, code=-240
0000071997 [system] INFO: Cloud: disconnecting
0000071999 [system] INFO: Cloud: disconnected
0000079699 [system] INFO: Cloud: connecting
0000084861 [system] WARN: Cloud socket connection failed: -2
0000085002 [system] WARN: Internet available, cloud not reachable
0000085002 [system] WARN: Handling cloud error: 3

Just out of curiosity, did you ever use this Photon with an external antenna?

There are still no log messages on the cloud side at all for that device ID.

Nope, I’ve always used the device as it is.

It’s odd that there aren’t any log messages: perhaps the handshake attempts are not logged?

I’m also experiencing the same issue. Followed all of the particle doctor steps, have tried using on home network and hotspot, have tried all of key reset steps as well.

Logs show:

0000154802 [system] INFO: Cloud socket connected
0000154802 [comm.protocol.handshake] INFO: Establish secure connection
0000155020 [comm.protocol.handshake] ERROR: Handshake failed: 6
0000155159 [system] WARN: Internet available, cloud not reachable
0000155159 [system] WARN: Cloud handshake failed, code=-240
0000155409 [system] INFO: Cloud: disconnecting
0000155411 [system] INFO: Cloud: disconnected

Also purchased device in 2016 and last used it in 2017.

Device information retrieved from the cloud:

Device ID	17002d000a47343432313031
Device Name	joyful-board
Online	false
Serial Number	PH-150626-QR4Y-0
Device OS Version	0.6.2
Last Handshake	11/5/2017, 12:36:19 AM
Last Heard	11/5/2017, 12:36:19 AM
Status	normal