Can't Install Photon USB Driver in Windows Vista

Just received my first Photon today. 1st problem (for another topic I guess) was not able to complete Android connection. Lots of digging led me to believe the firmware on the device is old, and has known bugs around this. It hangs after providing Wifi credentials. Hitting reset at that point didn’t help either as some posts I found mentioned.

So I thought I’d look at updating the firmware but hit a roadblock trying to get the USB driver installed. Been through most of the posts on this but can’t get it installed. I get “specified file not found” but can’t figure out what file can’t be found.

Anyone out there had this issue on Windows Vista know what the issue might be?

thanks

John

You should be trying to install DFU-util right?

My question is about problems installing the Windows USB driver for Photon, I thought I stated clearly!

Please give this thread a spin: [Particle Official] Windows 10 Full CLI and DFU Setup

If that doesn’t work… are you able to upgrade to Windows 7?

Thanks for that suggestion, unfortunately unless you have VISTA you might not appreciate the issue. Device manager doesn’t show Com ports, and in fact the Photon shows up under other devices in Device Manager. So I follow what would be regular steps to install a driver, it finds the driver file OK but complains about some file missing and so fails to install the driver. I can’t find anywhere what file it is complaining about. Btw, upgrading Windows is not an option.

Thanks for the feedback, though.

@kennethlimcp did receive your clear statement right, but you obviously misunderstand the meaning of his post.
For what you propose to be wanting you need the DFU drivers for Windows to recognize the Photon when it is in DFU Mode (the mode you need for local firmware update).
If you want to connect the device to be recognized as serial comm device you also need the serial USB drivers.

In order to help with your Vista problem, this is not very helpful

Screenshots and error messages usually give more info than that.

BTW:

That is an assumption! In fact Win 7 also shows the device in Other Devices unless the correct drivers are properly installed. Maybe Windows UAC is getting in your way.

So, just to say it out loud, the members who have answered your request do know things and have experience with multiple OSs. The way I understand your responses, you’re implying to know better.

1 Like

I can definitely appreciate how much a PITA vista is :wink: Hope this helps

3 Likes

Thanks for those steps. I tried all you said but when I got to install the driver I get this error consistently.

I’ve googled it exhaustively but have no idea what’s going on.

Hmm, ok maybe try this… remove the driver completely if anything has installed and then instead of installing the Communications Driver first…

When you get to this step:

Click HAVE DISK and follow that through to the Photon driver.

BDub, tried that too, similar result. :frowning:

Btw, the whole reason I’m trying to install these drivers is I need to reflash the Photon since the one I received yesterday in my order was obviously shipped with bad (old) firmware. I discovered this through reading old posts of others’ experience.

If I’m on the wrong track as how to do this please advise.

btw, thanks for your help, much appreciated.

and

and

Sure, @kennethlimcp and I are only members in this forum and not a reputated Particle employee, but I’d say this still stands.
At least when you have troubles with serial.

If you had bothered to accept this route and asked how to get these drivers (although described in the linked thread), you might have gotten a link to zadig

1 Like

Ok, ScruffR, I re-read your post and followed the instructions in the link. Installed DFU and zadiq, etc. I already had node.js and particle installed. I uploaded the firmware. And tehn I went back to my Android app to try and run Get Started. Again it fails after several seconds after I give the Wifi credentials, and the message "Uh Oh! Setup process couldn’t disconnect from the Photon Wi-Fi network. This is an internal problem with the device. … "

Any suggestions? Was I shipped a dud device?

thanks again

After resetting the device several times, I now find it “hanging” at the point in the Android app “Waiting for device cloud connection.”

Then after a minute I get an Error, 'Setup process couldn’t configure the Wi-Fi credentials for your Photon, please try running setup again etc ect"

You can flash individual binaries over serial now with the CLI:
particle flash --serial firmware.bin

@allegrojm With your device in DFU mode, if you run dfu-util -l what do you see as output?

This is what I see

Yup, but serial is obviously not working :wink:

@allegrojm, you said you wanted to update your device but then you didn’t or did you?

I stated above that I uploaded the firmware. And I pasted a screenshot. Did you not see that?

Just mentioning another way to update firmware is all :wink:

Yep! We are all talking to each other now and missed that :wink:

So that’s interesting… please try the more manual way of entering credentials:

  • Place Photon in Listening Mode (blinking blue) and keep holding SETUP for 10 second to erase all credentials
  • run particle serial wifi
  • enter credentials and see if it connects
  • if not press reset and wait to see what it does

But that ain’t going to work if I cab’t install the USB driver, right?

My bad - I obviously read over that bit - sorry :blush:

And I got stuck on the particle login mistaking it for particle setup so I ignored the “blurb” that usually comes with it :wink:

BTW: I just dug up an old Vista machine and will try to duplicate your serial driver issues.