Cannot setup my photon!

photon
Tags: #<Tag:0x00007f038f701040>

#1

I am working to set up my Photon I first tried the app but that didn’t work it gave me the error of “Set up process couldn’t claim your photon!..” I have typed the wifi credentials correctly and this same router has been used to set up other photons in the same day. I tried to use the Particle client through USB but it couldn’t find my device through USB so I tried using wifi but the client gets stuck on “obtaining device information”. Once seeing that it wasn’t going anywhere (waited about fifteen minutes) I restarted the photon by resetting the wifi networks and restarting the client this time I got the error of “Looks like your Photon has not connected to the cloud yet” I pressed check again but no avail so I choose the path of re-configuring my photons wifi settings which again sent me through a loop of “Obtaining device information”, I tried to be more patient but thought it shouldn’t take thirty minutes to do this when all my other photons took a minute. I started to try to see what I could do about updating my photon but I was never able to get my photon to show up via USB and it only shows up in my device manager as ‘Other devices’.

I am really at a loss here I have been reading through as many relevant forms as possible but this same issue is happening to three of my six photons so I would really like to get them working! Here are some snips of the issues I am having.


#2

What does the RGB LED do on your Photon?
Have you put the Photon into DFU Mode (blinking yellow) in order to update the device?
Have you installed CLI via the Windows Installer?
What CLI version are you running?
What is the device OS version of your Photon?
Does your Windows recognise the other/working Photon (in DFU Mode or as COM port)?

You can try to zadig to install the DFU drivers.


#3

The driver installer got me a step closer now the Photon is not able to detect the Network I am aiming to use. Even though I used this Network to connect the other Photons I set up.


#4

Additionally this is what I got when I moved my location closer to the router.


#5

The CLI Installer or the Zadig tool? The node .js errors would suggest that you run the full CLI installer again (do not use the npm or node command-line update method.) Can we assume Windows 7 from the screen captures?


#6

Yes windows 7and I meant the Zadig tool. Let me give that a shot


#7

That is giving me the same loop of issue what exactly do you mean by node command-line update method?


#8

If you aren’t doing it… then don’t worry about it. Just know for Windows, download the full CLI installer from here and run it again if you haven’t already done so.

https://docs.particle.io/tutorials/developer-tools/cli/


#9

I tried the re-installation - this whole deal is making me think there could be damage to my photons cloud connection hardware (I am not a hardware person). Do you think it is possible?


#10

If you are talking about damage to the WiFi modem, I would say that is unlikely. More likely a problem with your installation. You could also try running the installer as admin (right-click on the .exe file and select “run as admin”.

You could also answer some of @ScruffR’s other questions:


#11

Running as admin is not working either I am at a loss here.


#12

Here are some questions and suggestions…

  • The first thing that we need to sort out is the Device Manager listing for the Photon. That should say “USB Serial Device (COMxx)”. Was that fixed by the “driver installer” that you mentioned on Jan 21?

  • Assuming that it was – if you power up the device without pressing either button, and then press/hold the MODE (left) button, does the RGB LED go to blinking dark blue after four or five seconds? That is Listening mode. You could set up the wifi creds while it’s in that mode (rather than using CLI) by connecting a terminal emulator (e.g. TeraTerm, which is what I use) to the Photon and then pressing “w”. It will then lead you through configuring the wifi creds for your network.

  • (I don’t think Zadig is required if you install the latest CLI using the Windows installer (vs. npm install). The driver installer in the Windows installer was recently updated to install/configure the correct drivers for all Particle devices.)

  • if you type particle --version, CLI should return “1.38.0” if it’s installed correctly and if it’s the latest stuff

  • if you decide to use CLI to configure wifi, don’t let it scan for networks, and enter the SSID yourself. The device has to be in Listening mode for this. Assuming it doesn’t error out, if you entered the SSID and passphrase correctly, the device should reboot and eventually get to breathing cyan.

  • if all of that fails, I suggest you re-flash Device OS (the system firmware) and the Tinker app by downloading https://github.com/particle-iot/device-os/releases/download/v1.0.0/system-part1-1.0.0-photon.bin and https://github.com/particle-iot/device-os/releases/download/v1.0.0/tinker-1.0.0-photon.bin, put the Photon into DFU mode, and from the directory that you downloaded the binaries, type

particle flash --usb system-part1-1.0.0-photon.bin
particle flash --usb tinker-1.0.0-photon.bin

and then after the command prompt returns, reboot the Photon.

Let us know if any of that works. If now, let us know what the RGB LED ends up doing.


#13

@amandaW I had a similar issue today with one of my photons. It looks like about the same error message, I can’t be completely certain. Anyways, what seemed to fix it for me was, while I was in the CLI, I re-logged into my account. It might be something with the login timing out. Just a suggestion.


#14

Did you omit system-part2 for any particular reason?
However, with CLI v1.38.0 you should just need

particle update 

to install the latest official device OS (all system parts) and follow that up with

particle flash --usb tinker

Depending on the version you are starting off of, you may also need to update the bootloader in Listening mode via

particle flash --serial bootloader-1.0.0-photon.bin

Sometimes when there already was a CLI installtion the Windows Installer fails to install the DFU drivers (for reasons unknown to me).
It would be good if there was a standalone driver installer, but for the lack of that (or my ignorance about its existance) zadig is certain to help.


#15

Standalone driver installer: https://github.com/particle-iot/windows-device-drivers/releases/download/v6.1.0.68/particle_drivers_6.1.0.68.exe


#16

Is there a link to that in the docs?
If not, that would be good.


#17

@ScruffR I don’t know offhand, but will ask that it be added if it’s not.