[SOLVED] Photon Initial Setup Issues

I just looked at your screen shot. The device is showing up under Ports! You’re good to go

I believe it is an unrelated, at least that is what I have been assuming, when I unplug the Photon COM1 is still visible. Here is an image, you can also see the USB devices section is no longer there, that is where the Photon appears.

Sorry, false call. Ok, so what is the device on COM1? Is it the Photon? When you unplug the Photon, does that device disappear? If so, you should try uninstalling both those devices and then, unplug your photon, and plug it back it. If it show up under Ports but doesn’t say “Photon” then manually install the drivers for the device under Ports

Ok, try uninstalling the device under the USB devices section (plug in the Photon first)

I have not read the whole thread again, so things I’m saying might have been said and tried already.
Still, to reiterate, you might need to remove any previously installed Particle Serial USB drivers.
This can be tricky since Windows - by default - won’t show you drivers not currently in use.

To get around this, try following this procedure (shown for XP, but still applies to 10)

When you’ve done that, you should now see Particle drivers (if you ever had them installed) and can remove them and any other drivers which might have been used for the Photon.
Make sure to tick the “Remove from system” checkbox in order to get rid of them completely.

After that reboot the system, then open DevMgr again to see if there are any remainders and see where a newly plugged-in Photon will appear.
It should come up as COM port. If it doesn’t you can try zadig - which you should have or will need for DFU driver install anyway - to force feed Windows the USB Serial (CRC) drivers.

After that you should be good to go.

1 Like

@ScruffR I tired your instructions and the device is now showing up as a COM port! Thanks!

I am now trying to get the device to connect to the cloud but have been unsuccessful. I have followed the direction in the tutorial, but keep getting the message “it doesnt look like your Photon has made it to the cloud yet”. The Photon is flashing cyan and sometimes orange/red without connecting. I followed the instructions at the following link: https://docs.particle.io/support/troubleshooting/common-issues/photon/
I started by updating the firmware to 0.6. I again tried to connect, but still had issues. Went to the next section and attempted to do a public key reset, but have run into issues at this point and havent been able to figure out what to do. Two options are offered 1.) if you have claimed your device before and 2.) if you have not…I have tried both. Here what happens:

1.) When I try the “havent claimed device before” and use my cmd to navigate to “this file” as specified in the instruction I get the following note. I have tried this dfu mode, sensing mode and the cyan mode w/ red orange.

2.) When I try “previously claimed” I get

I have been searching and cannot figure out whats going on. I appreciate all the help, this software stuff is new to a mechanical engineer :smile:

The error message is saying it doesn't know what openssl is. If you've installed open ssl, it's not on the path. You need to add the path to where you've installed openssl to your System Path.

I had this issue recently when one of my Photons lost it's keys. Check out this post

Be sure to close your command window and open a new instance after you set up openssl path in your System Path. The currently selected item in the bottom path of the window in the attached image

Since you are on Windows you can use the Windows CLI installer that should bring all the required 3rd party tools and set them up properly.
Just remove CLI with

npm uninstall -g particle-cli

and reinstall fresh via the installer.

@ScruffR I just tired your approach ( I have been working on @shiv’s approach, but have been running into issues with openSSL- probably a user error) I removed CLI successfully and ran the installer you recommended. At the end of the installation it said I should run ‘particle setup’ when I run this I get the result below. The Photon is showing up in my device manager as a COM port and it is in ‘sensing mode’.

Do you consider this good or bad?
I'd think it's fine :wink:

Do you mean listening mode (blue flashing LED? If so then you now need to set up your WiFi so your photon can connect to your WiFi router.

So now do
particle setup wifi

@ScruffR I consider it good! One problem solved! Now onto the next…as @shiv recommended I run ‘particle setup wifi’ when I do this this I cannot get the particle to connect to the cloud. It flashes cyan and everyone in a while does an orange/ red flash. This is the point where I am stuck and cannot get passed.

also, I tried the solution as recommended by ScruffR to shiv when he ran into the same problem:

when I tired this I run into an openSSL issue which is when I ran the "windows CLI installer" which has the openSSL program. The cmd prompt is below.

@mbresman, do you know how to add openssl to your system variable’s Path? 'cause that’s what you need to do.

In Windows 10

  1. Press Windows Key and type (blindly) “Advanced System Settings” or “Environment Variables”

  2. You’ll see your start menu pop up and an icon representing the “Advanced System Settings” control panel applet

  3. Click on the Environment Variables button
    Now you’ll see the screen shot I posted earlier. Make sure you pick the “Path” variable from the System Variables list (the lower List box and not the Top list box)

  4. With the “Path” variable selected, click the “Edit” button

  5. Next dialog, click on the New Button

  6. In the new line that is created paste in the path to where you’ve installed openssl. For me, it is the below. Note that the path should end with a back slash.


Also, remember to close and open command windows. And open a new one and then do the particle keys doctor CLI command

Have you restarted Windows after you reinstalled CLI?

Any open cmd instance will not get the updated PATH settings which should be set correctly by the installer too.

Ok so maybe 3rd time is a charm, its working! I have done a number of restarts in between steps as you recommended @ScruffR for some reason it worked this time, not sure what changed. But I am now able to connect the Photon to the cloud, it is breathing cyan and control it with my phone! Thanks for all the help guys! Now onto the next steps in the tutorial.

@ScruffR @shiv @Moors7, next beers on me if you are in the SF Bay Area south bay!


That’s great news @mbresman!

1 Like