Argon stuck in DFU mode

Hello everyone,

So I was playing around with my argon + 5 xenon mesh and I was having troubles getting my code to upload with rc26. I was thinking of resetting the wifi to go through the setup process again and accidentally did a factory reset (I think) and I am now stuck in DFU mode…

I have installed the CLI and the particle dev app for windows and I’ve tried the following commands based on the limited info I could gather about this subject:

dfu-util -d 2b04:d00c -a 2 -s 0x80200000 -D system-part1-0.8.0-rc.26-argon.bin (to no avail)
dfu-util -d 2b04:d00c -a 2 -s 0x80200000 -D tinker-0.8.0-rc.26-argon.bin (to no avail)

dfu-util -l gives the following response:

dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

Found DFU: [2b04:d00c] ver=0250, devnum=32, cfg=1, intf=0, alt=2, name="@External Flash   /0x80000000/1024*004Kg", serial="e00fce6893f55ebdc89e074c"
Found DFU: [2b04:d00c] ver=0250, devnum=32, cfg=1, intf=0, alt=1, name="@DCD Flash   /0x00000000/1*016Ke", serial="e00fce6893f55ebdc89e074c"
Found DFU: [2b04:d00c] ver=0250, devnum=32, cfg=1, intf=0, alt=0, name="@Internal Flash   /0x00000000/1*004Ka,47*004Kg,192*004Kg,4*004Kg,4*004Kg,8*004Ka", serial="e00fce6893f55ebdc89e074c"

Before I cause more harm to my argon, hopefully someone here knows how to fix this problem.

Rather than using DFU directly, try using the CLI with particle flash --usb [file.bin]. That way, you don’t have to worry about the addresses and commands.


Those are not the right dfu-util commands. The system and user firmware are in -a 0, not -a 2, and the addresses are wrong. As you can seriously corrupt your device using incorrect dfu-util commands, you should use Moors7’s suggestion of particle flash --usb instead.


Thank you for your input.

Yesterday I tried this, but I think the CLI can’t find my argon?
In device manager I see the argon in DFU mode (had to install the appropriate driver first using Zadig).

So in the command prompt I typed:
particle flash --usb [tinker-0.8.0-rc.26.bin] also tried with the path to the directory where the file is actually stored.

Am I using the CLI command correct? Or is there a way to check if the problem lies elsewhere?

You would not put the file name in square brackets - when @Moors7 showed you the command he meant to replace the whole [...] part like this

particle flash --usb tinker-0.8.0-rc.26.bin

But before flashing tinker you need to flash system

particle flash --usb system-part1-0.8.0-rc.26-argon.bin -v

(-v for verbose output)


Thank you very much! This seemed to fix it!

Have to do some more testing with uploading new sketches to be certain though.

I had the same problem and it fixed mine also., Thanks

1 Like

Hello, I tried this solution and get the following

Error writing firmware: file does not exist and no known app found.
VError: Error writing firmware: file does not exist and no known app found.
at C:\Users\edeleon\AppData\Local\particle\node_modules\particle-cli\dist\cmd\flash.js:156:10
at process._tickCallback (node.js:401:9)
caused by: Error: file does not exist and no known app found.
at C:\Users\edeleon\AppData\Local\particle\node_modules\particle-cli\dist\cmd\flash.js:86:12
at process._tickCallback (node.js:401:9)

might you be able to help. I think I might be missing a step. Thank you

Did you download the respective files and executed the command from the location where that file lives?

BTW, at this point in time you should rather use the rc.27 binaries.
Here is a more elaborate post with instructions and download links

1 Like