Photon setup flashing cyan with a "quick red burst" (now orange burst) [Solved]


#21

@mdma thanks this is the solution !


#22

How do we fix this if it has been claimed and been connected to the cloud?

I messed mine up flashing the develop branch somehow… ive tried sending new keys and it says success but i get the same rapid cyan and red burst…


#23

@Hootie81,

try to reflash the Particle :cloud: keys in DFU mode with:

Download the server public key from https://s3.amazonaws.com/spark-website/cloud_public.der

dfu-util -d 2b04:d006 -a 1 -s 2082 -D cloud_public.der

[SOLVED]Photon fast blinking cyan (with a random red burst)
Photon Troubleshooting Guide (as of Firmware v0.4.6)
Particle does not attempt to connect to wifi
Photon pulses white constantly
#24

You @kennethlimcp are an absolute legend! that did the trick… had me stumped for 3 days!!!


#25

I was faster. Took me a day :wink:


#26

If anyone else has to relash the public key, it would be great to first save the existing key for later analysis. So before updating the public key run:

dfu-util -d 2b04:d006 -a 1 -s 2082:512 -U cloud_public_from_device.der

If flashing the cloud public key works, then please PM me and send me the cloud_public_from_device.der file so I can investigate!

Thanks!
mat.


#27

I have the same problem with a previously claimed and connected device. Tried your suggestion. Didn’t help. My other photon is working fine. I saved the cloud_public_from_device.der.

What are my options?


#28

Please try generating a new device key, as described above, and then put the device in DFU mode and run

particle keys load mykey
particle keys send <DEVICE_ID> mykey.pub.pem

This will regenerate a key on the device and provide it to the cloud, which is allowed, since you have already claimed the device.


[SOLVED]Photon fast blinking cyan (with a random red burst)
#29

so here I am having this same issue; and I tried this:

and that didn’t help, so I did this:

and I still get the cyan flashing with brief periods of red, like @avidan, the OP

not my day I guess!

EDIT

for the record, @kennethlimcp helped me solve my problem via a PM.

I wanted to give @kennethlimcp props for being so helpful to this forum, and to me personally, so BIG THANKS @kennethlimcp!!!


#30

Would you mind sharing the solution in case others hit the same problem?


#31

Right, yes!

reset the device keys (as above)
reset the public key (as above)

and finally…

@kennethlimcp:

Can you do a particle keys send deviceid device.pub.pem

We might really have to wait for Mat to give directions on this.


Photon is unable to connect to wifi after flashing static IP code. [ SOLVED ]
#32

In summary:

  • particle keys server cloud_public.der
  • particle keys new photon
  • particle keys load photon.der
  • particle keys send photon.pub.pem

Cannot claim Photon - SOLVED
Photon cannot connect - rapid blinking cyan [SOLVED]
Photons unable to get in safe mode
Particle can't connect to cloud after I flashed it
#33

Ok, so this was on a Photon that was already claimed?

I’m curious to know what made the installed keys go bad?


#34

That I cannot answer except that I attempted to add the Photon to a new wireless network, after I claimed it (out of the box) on another WiFi network.

I went through WiFi setup and it never made it past flashing cyan.


Cannot setup Photon
#35

I have tried connecting my Photon through 1) Particle CLI setup and 2) Particle iOS setup.

Each has resulted in flashing cyan lights with a red flicker occasionally.

Can someone help troubleshoot so I can get this Photon connected?

Particle CLI Experience:

$ particle setup

Setup is easy! Let’s get started…
It appears as though you are already logged in as MYEMAILACCOUNT
? Would you like to log in with a different account? No

! PROTIP: Hold the MODE/SETUP button on your device until it blinks blue!
! PROTIP: Please make sure you are connected to the internet.

I have detected a Photon connected via USB.
? Would you like to continue with this one? Yes
! The Photon supports secure Wi-Fi setup. We’ll try that first.

! PROTIP: Wireless setup of Photons works like a wizard!
! PROTIP: We will automagically change the Wi-Fi network to which your computer is connected.
! PROTIP: You may lose your connection to the internet for a moment.

? Found “Photon-XXXX”. Would you like to perform setup on this one now? Yes

! PROTIP: You will need to know the password for your Wi-Fi network (if any) to proceed.
! PROTIP: You can press ctrl + C to quit setup at any time.

Hey! We successfully connected to Photon-XXXX

Now to configure our precious Photon-XXXX

! PROTIP: I can only scan for Wi-Fi networks that broadcast their network name (most networks do).
! PROTIP: If you want to skip scanning, or your network is configured as a non-broadcast network
! PROTIP: answer yes to the prompt below. Otherwise, we will continue with the Wi-Fi wizard setup process…

Would you like to manually enter your Wi-Fi network configuration? No
Please select the network to which your Photon should connect: xxx
Please enter your network password (or leave blank for none): xxx
Here’s what we’re going to send to the Photon:

Wi-Fi Network: XXX
Password: XXX
Security: XXX

? Would you like to continue with the information shown above? Yes

Obtaining device information…

Obtaining device information…

Obtaining device information…
Requesting public key from the device…
Setting the magical cloud claim code…
Telling the Photon to apply your Wi-Fi configuration…
The Photon will now attempt to connect to your Wi-Fi network…

Configuration complete! You’ve just won the internet!
Would you like to return this computer to the wireless network you just configured? Yesnfigured? (Y/n) Y
Fantastic! You should be back to normal now!

! PROTIP: Your Photon may start a firmware update immediately upon connecting for the first time.
! PROTIP: If it starts an update, you will see it flash MAGENTA until the update has completed.

Ok, bye! Don’t forget particle help if you’re stuck! <3

$ particle list

No devices found.

$ particle device add DEVICE_ID

Claiming device DEVICE_ID
Failed to claim device, server said { ok: false, errors: [ ‘Device is not connected’ ] }

$ particle identify

! serial: Serial timed out
Potentially unhandled rejection [2] Serial timed out (WARNING: non-Error used)

Particle iOS Experience:

Login to Applcation
Your devices
Setup a Photon…
Ready
Find Photon Listed in Network
After selecting Photon newrok, push notification returns to App
When I return to the app, I get a prompt saying:
Product ownership
This Particle device is owned by another user, do you wish to change ownership to EMAIL_ADDRESS?
Select Yes
Select wifi network
enter password
connect/join
Setup failed
Setup process failed at claiming you Particle device.

RESOLVED: device keys and cloud settings got messed up. once this was fixed photon back online and connected


Photon losts its credentials!
#36

@Ashton, if you don’t mind, can you tell me how you fixed the keys issues? So that i have some idea of what users are doing when things fail.

Thanks! :wink:


#37

Just wanted to let everyone know that apparently keys can get corrupted at brown outs. I tried running
my Photon directly off a 10W USB solar charger that is one of the simple ones where it outputs voltage even if it doesn’t get 5V. It reset a few times and I wanted to see whether it would boot once the sun is out from the clouds. After that it first
only flashed blue, then I set up the WiFi and it flashed cyan with intermittent red. Reflashed the 0.4.3 firmware but that
didn’t help. Then I regenerated the key and sent it to the cloud and that finally did the trick.


#38

Could you help why I get this error?

C:\Users\Amir\Downloads>dfu-util -d 2b04:d006 -a 1 -s 2082 -D cloud_public.der
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Opening DFU capable USB device...
ID 2b04:d006
Run-time device DFU version 011a
Claiming USB DFU Interface...
Cannot claim interface

#39

Are you using a USB3.0 port?


#40

I use a USB2 port.