[SOLVED]Photon fast blinking cyan (with a random red burst)

Greetings everyone,

Huge Particle fan, first time poster!!!

I have several Core’s that are all working fine (Love it). I have one Photon that I am trying to get working again. At one point I had it up and connected; but, I had issues with trying to get it to print to the serial port. I had read somewhere that it needed to be upgraded to the latest firmware. I went a head and flashed it with the latest firmware and it did connect, but didn’t fix my issue. Somehow, I put this thing in a state where it won’t even connect anymore. It now is blinking a fast Cyan color with a hint of red every so often. I have opened up a support ticket with Particle a few days ago, but no response yet. Does anyone know why or what is wrong with this thing. I have a urgent need to get this back on-line to use in an upcoming demo for my company. Any help or guidance would be greatly appreciated.


Have you not seen this?
Photon setup flashing cyan with a "quick red burst" (now orange burst) [Solved]

1 Like

Actually yes… I did find that post. It’s not working for me… I have tried several times to get this thing back up and running with no luck… STUCK…


Here is what I had to do…

Note: To find your device id make sure your photon is plugged in to the USB port and in DFU mode. Then use this command. particle identify

1.) Put the Photon in DFU mode (blinking yellow).
2.) CMD: particle keys save mykey
3.) CMD: particle keys send DEVICE_ID mykey.pub.pem

4.) reset the device (unplug from USB and plug back in)

5.) Perform setup CMD: particle setup


1 Like

Looks quite similar to the suggestions in the quoted thread :wink:

Photon setup flashing cyan with a "quick red burst" (now orange burst) [Solved]

I tried this.

This didn’t quite do the trick until I followed up with this.