Photons unable to get in safe mode

How can I update the firmware without being connected to the cloud?

It sounds like your device is unable to reach out to the cloud. Can you double check that port 5683 isn’t blocked by a firewall?

The device is still trying to get into safe mode, but is being hindered by not being able to connect to the cloud.

Hi @mdma, if you mean the firewall of the router through which the Photons dialogue, it is set at LOW (filtering disabled). In any case I have not changed anything on the router since last time I was working on the Photons and flashing in safe mode.

Thank you.

In troubleshooting a seemingly unrelated problem, I’ve also not been able to enter safe mode at all. Same sequence of blinks with the same button input and DFU mode and serial/listen mode work fine.

I also am unable to register my photon in the final authentication step of the phone app, manually in the web IDE, or through the “device add” command of the CLI - perhaps this is related. This is also on a network which had been fine a week or two ago when I was last working with the photon actively.

Is there any way to factory reset the chips and flash them again?

There is, but don’t think that would help in this case. The device is connecting to wifi, but not making the connection to the cloud. There are 2 possible causes:

  1. the device cannot reach the internet

  2. the keys require updating

for (1), double check your router, firewall etc to be certain the device can connect to the internet.

For 2, please see Photon setup flashing cyan with a "quick red burst" (now orange burst) [Solved]

Hi @mdma, thank you for your answer.

I have checked my router. The only thing I did previously was to set 2 bundle addresses in the ‘bundle adress list’ (LAN/DHCP Setting) to get always a fix address for both photons. I have removed that without improvement. For the rest, settings are by default and did work end of last year when I left my work.

In reference to the thread you mention, in my case I don’t have the ‘quick red/orange burst’ showing bad keys.

These are more weird behaviours I have noticed:

a. With ‘particle setup’, I cannot wifi access to the photons (No nearby photons detected…), listening mode is ON.

b. going to DFU mode (yellow flashing), dfu-util -l (thank you for posting an exe file) reports:
'Cannot open DFU device 2b04:d006’
And I get exactly the same message if I put both photons in DFU mode.

c. one of the photons cannot go to ‘listening’ mode! (the setup button is ineffective).

d. ‘particle list’ reports:
"Retrieving devices… *******************
Please login = it appears your access_token may have expired

listDevices got error: invalid_token
Potentially unhandled rejection [2] invalid_token (WARNING: non-Error used)
Potentially unhandled rejection [3] invalid_token (WARNING: non-Error used)

I know… it’s a mess!
And all this by just restarting the system after a stop of 2 months.

JM

What localization/language are you using on your system?
If it’s anything but English (or German with version 1.9.2+) the WiFi scanning might not work.
What OS are you using?

Hello @ScruffR,

I am using the English language with the OS and the IDE. My OS is Windows 7 64bits.

I would like to precise that the solution was working perfectly in December until I restarted early this year.
I did program both photons off-cloud (using SYSTEM_MODE(MANUAL)) by flashing them in safe mode without any issue.

Both programs (data are trandfered from an Arduino to the client photon by I2C, then sent through the wifi modem to the server photon connected to the laptop) are still working today. The probe leds are flashing at the rate of transfer and I can monitor the data from both serial links.

My only issue is that I cannot go back anymore to safe mode to flash the photons, as I did before.

Thank you.

JM

Did you ever resolve this issue? I’m having the same problem and cannot get to safe mode, same series of flashes and no resolution yet.

I’m having a similar problem. I cannot get into safe mode, just jumps out of magenta, shows solid when then flashes green. I can get to DFU mode, and I can flash (tinker). However, whether I reset WiFi (hold down mode button until it flashes blue), and try to setup via an Android device, or whether I use CLI, the same thing happens. It never starts flashing or breathing cyan during the setup process, however, which is the opposite of the other 2 devices that I have working. That is, although it appears to be working correctly from the display of the android device, it eventually fails on an error during the last step.

Using the CLI: (I’ve updated the CLI to the latest version)

$ particle serial wifi
? Should I scan for nearby Wi-Fi networks? Yes
? Select the Wi-Fi network with which you wish to connect your device: Slow Ireland
? Should I try to auto-detect the wireless security type? Yes
Detected WPA2(PSK/AES/AES) security
? Wi-Fi Password xxxxxxxxx
Done! Your device should now restart.

– just flashes green at this point, never went to cyan flashing or breathing.

I’ve used the same Android device to setup 2 other Photons with no issues. However, those did start flashing cyan and breathing cyan during the setup process where the failing one did not.

Again, trying to enter Safe Mode fails in that it doesn’t stay in flashing magenta but rather jumps to white then flashing green.

I also tried updating the firmware, which did update it, but that didn’t fix the problem, still cannot get into Safe Mode.
Your system firmware version is 0.5.3. after update goes to 0.6.0. Still doesn’t enter Safe Mode.

I also installed the Tinker app from DFU mode, which appeared to work correctly. However, still no Safe Mode.

That is “normal” given the circumstances.
The normal color sequence would be

  1. white
  2. blinking green
  3. rapid blinking green
  4. rapid blinking cyan
  5. magenta breathing

Does our device stall at 2 or 3? Or are you seeing any short red bursts?
It seems your device can’t acquire a valid IP from your router.
The question is why you can’t connect to your WiFi.

Can you post a video of the failing normal start and Safe Mode with at least 15 sec on the final color?

There may be multiple reasons, some of which may be in connection with your WiFi network like no more free DHCP IP addresses, MAC filters, interfering 5GHz network, …
Or your device might have been set for staticIP which is not available on your current network.

Can you try to wipe all the stored WiFi credentials (press’n’hold SETUP 10+ sec till rapid blue blinking).
Try to connect to a different AP (e.g. your mobile hotspot).

I always prefer to not rely on the auto-scanning features, since I do already know my turf :wink:

I have this problem, mine is “stalling” at number 4, rapid blinking cyan

And have you checked all the prerequisites stated above?
Any additional color codes in between rapod cyan?

to begin with it sometimes gives one red blink in between, but eventually it will only rapid blink cyan. I have tried to connect it to WiFi again, both using CLI and the android app… if I use the app it sometimes will stall at the this spot

and then after few minutes it will give me … not sure if it helps to know that… sometimes I can get through this setup in the android app but if that happends then it still will not get the LED breathing cyan

and now it is showing a different behavior… it is blinking cyan for few seconds and then a few very fast cyan blinks and then (like when it is just about to connect) and the it gives one red blink (at the moment when it should give breathing cyan)

This would indicate a keys issue. To cure that try

particle keys server
particle keys doctor <deviceID>

I am having a similar problem. I got into this mess by using “while” loops. I didn’t use Particle.process. Now I will. But adjacent to that problem is my setup button will not activate any modes. The only colors that appear are yellow and green. When I try to put it into “safe mode” it goes yellow. THis is my method for safe mode…

  1. I hold both buttons down
  2. I release the reset button
  3. I wait and hold the setup button until it turns magneta.
    -it never turns magenta. It goes from a red/blue light to a yellow light. It never changes from a yellow light no matter how long i hold down the setup button. If I release the setup button before it blinks yellow it blinks a strange red light/blue light that isn’t referenced anywhere. This isn’t a case of me not knowing the colors. I’ve tried safe mode hundreds of times. It’s never blinked or breathed magenta. The setup button is not allowing me to reset the wifi network or factory settings. THe setup button is not responding. If i press the reset button
    it goes from green to cyan, then back to breathing green after about 10 seconds. I need a solution that doesn’t tell me to use ‘safe mode.’ I can’t access safe mode and I can’t access the cloud. What is left to try?

If you have not done so already, please install the Particle CLI. The command line utilities are useful not only for solving this problem but will be valuable later on, as well.

https://docs.particle.io/guide/tools-and-features/cli

If you are using Windows, be sure to use the link to Windows CLI Installer that will automatically install all of the components instead of the more complicated manual install.

Put the Photon in DFU mode (blinking yellow) by holding down RESET and SETUP, releasing RESET and continuing to hold down SETUP while the main LED blinks magenta until it blinks yellow, then release.

Then enter the command:

particle flash --usb tinker

It’s also a good idea to put the Photon back into DFU mode (blinking yellow) and do:

particle update
1 Like

You da man!