Issue with Photon, will not connect, error code 1

Hey all,
I have a photon that was working fine reading temperature. The device stopped sending and was blinking red when I finally went to retrieved it. I cannot get it into safe mode. I tried to update the photon using CLI, “particle update”, but I get >Error code: 1

I also tried to use the particle firmware update utility (usb) but it tries to update the firmware to 0.5.2 and fails, it was on 0.5.3

When it attempts to connect, the flashing cyan fast for several seconds, then flashes fast red, then goes back to cyan flashing like its trying to connect to the cloud.

Then after a while, it just flashes red (fast) not the SOS patterns.

Here is the last config in the cloud
"id": “21003xxxxxxxxxxxxxxxxxxxx”,
“name”: “photon007”,
“last_app”: null,
“last_ip_address”: “”,
“last_heard”: “2016-09-22T13:45:03.891Z”,
“product_id”: 6,
“connected”: false,
“platform_id”: 6,
“cellular”: false,
“status”: “normal”

Is this thing toast?


So DFU mode does work?

I don’t think so, I tried to “particle flash --usb tinker” and got the error:

Error: writing firmware…dfu-util is not installed

That’s a pretty obvious error; have you tried installing DFU Util?

@Moors7 , I appreciate your help, please forgive my ignorance. I had followed the instructions to install the particle CLI some time ago, I thought they included the dfu utilities on my local system–I checked and they had been installed on my local system. One difference I see on my Win 10 system is there is no path set in my environmental variables for dfu utilities, it was set before. I fixed it. I did download and install the dfu utilities when I installed the particle CLI.

I could flash other photons, as well as use OTA with other photons. This one is not behaving, I can’t flash/update the firmware via usb. A bad assumption of mine may be that if I can flash firmware via USB to other photons, I should be able to flash this one.

Now that environmental variable path was reinstated, I get a new error that stated:

“I was unable to detect any devices in DFU mode…”

However, the photon is blinking yellow. My understanding was that the blinking yellow indicated the photon was in DFU mode.

What am I doing wrong?

@Ledbelly2142, for DFU flashing you also need to have installed the Zadig driver for that device. Have you done so?

In that case, could it be that the USB connector on the device has got some issues?

With the DFU Utility update, I can flash the photon through the CLI, says it successfully loads. But I still have the same problem, blinks red and fails to connect to the cloud.

If this red flashing is a quick red burst while blinking cyan then try

particle keys doctor <yourDeviceID>
particle keys server

If it’s not, post a video of the color codes (+10sec either side of the red blink)

@ScruffR Thanks for your suggestion. When put the photon in DFU mode (blinking yellow), and attempt to use “particle keys doctor” with the device ID, I get the response that there is no DFU connected device. The error:
“I was unable to detect any devices in DFU mode…”
Your device will blink yellow when in DFU Mode.

Here is the video when the photon tries to connect to the cloud:

Could there be something wrong with the usb driver? It seems ok in my device manager (image)

You said

If this was true, you will also be able to do particle keys (this might only ask for OpenSSL to be installed if not already present)
Otherwise try reinstalling the DFU drivers via zadig, try a different USB port and/or cable.

1 Like

Yes, I could flash other devices. I can no longer flash this Photon. The error I get is:
“I was unable to detect any devices in DFU mode…”

Is there another way to load firmware on a Photon?