Photon cannot connect - rapid blinking cyan [SOLVED]

After running my pulse counting sketch for a few days. My particle started blinking blue rapidly.

I tried resetting it but it kept blinking blue. Then I realized that FW 4.4.0 is out so I flashed (via DFU) it in. Now I can’t get my Particle back on a WiFi network (tried two different) from both the cli and the Android app and my Particle just keep blinking blue.

Directly after powering it is blinking rapid red once in a while. But the problem is that I can’t get it to stick with WiFi settings.

Serial connection works fine.

Any suggestions?

The usual first suggestion for the Photon would be to try “Safe Mode”.

But looking at your vid, this might be useful too
Rapid cyan followed by rapid red flashing [After switching back from Local Cloud][Solved]

I can’t get it to stay in safe mode. While following the guide after releasing SETUP my Photon directly goes to SOLID WHITE (~5s) -> BLINKING GREEN (~3s) -> the same as the video above.

I did try to do fix the keys, but I’m afraid I also ran particle keys server. Can that be the problem (that my Photon is trying to connect to a non existing cloud)?

Edit: Followed the instructions here Tutorial: Local Cloud 1st Time instructions [01 Oct 15] to download the cloud_public.der file and updated my Particle with:

particle keys server cloud_public.der 

And now it is working again. Somehow it lost the cloud key.


Darn, there are so many topics with similar titles, I actually wanted to refer you to this one
Photon setup flashing cyan with a "quick red burst" (now orange burst) [Solved]

But anyway, glad you got it working :+1:

I’m not sure what I did to make it this way, it just started misbehaving one day…

I actually tried to read the doc and forum but could not find anything regarding server keys. (Didn’t know what I was looking for). Perhaps the server-key issue should be mentioned in By trial and error I think the green mode actually “trying to connect to WiFi” and not “can not reach cloud”.

It’s hard to tell on your video, but for me the color looked cyan (green + blue sub LEDs together) in it.

I’ve no idea how this could have come about, but maybe @mdma has got an idea (and could trigger a doc update ;-))

Yes, my Photon is probably cyan alternating to red in the video (as referred to in the docs).

But if I shut down my router my Photon will blink green when booting up, not “breathe blue” as refered to here: