Photon setup flashing cyan with a "quick red burst" (now orange burst) [Solved]


#41

I suddenly tonight am having this issue with three Photons that had previously connected to the cloud and were previously working fine… I normally have them operating in SEMI_AUTOMATIC mode (connecting to Wi-Fi but not the cloud), but went to connect one of them to the cloud to re-flash. Instead of connecting successfully like normal it flickered cyan with red bursts. I thought something must have happened to this Photon so I tried one of my other ones, and it did the same thing! Then another! All in the same night… I have a big meeting tomorrow so this is horrible timing, and I can’t seem to get dfu-util to work to try new keys, I keep getting “No DFU capable USB device available” even though I have installed the drivers with Zadig and have the Photon in DFU mode. Any ideas how I can fix this with my Photons ASAP!??


Cloud thinks my Photon is a Core
#42

I was able to update the keys and get rid of the red bursts by switching to a Mac (instead of my Windows machine) which was able to recognize the Photon in DFU mode, then following the steps provided by @mdma here. But what the heck could have caused this?


#43

This often doesn’t help ;):

There are so many odd quirks in Windows that can seriously mess up pretty much anything, itself included. Try uninstalling all the particle drivers, and installing them again. That might help. Using different USB ports/cables can also make a difference.
As to what may have causes the red bursts, not really sure…


#44

Wow that’s terrible luck to have all 3 fail, sorry for that. If you’re able to reproduce the problem I’d love to know how so we can investigate.

If it happens again, please make a dump of the memory using this command (with the device in DFU mode), and send me the resulting file:

dfu-util -d 2b04:d006 -a 0 -s 0x8000000:0x100000 -U dump.bin

Thanks!
mat.


#45

@mdma

I have the exact same problem and have tried everything in this thread. I have made a dump of the memory, where should I send it?

//Henrik


#46

Thanks @mdma, if I encounter the issue again I will try to note the specific steps leading to it. I’ll also save the memory dump file and send it your way! One strange thing to note from what happened to me Monday night is that the third Photon I tried wasn’t even running the same firmware as the other two when I connected it to the cloud and saw the cyan flashing with red bursts.


#47

I have recently experienced the same problem as described in this thread. After ‘reseting’ the keys, my Photon is recognized as ‘online’ in the developer Dashboard, but it is not properly recognized in the Android App or the Web IDE.

I started experiencing this problem with all of my devices: 2x Photons and 1x Core. (although, I don’t spend much time troubleshooting the Core)


#48

!!! Exclamation points!

I put my Photon in my project after it was working flawlessly and I got these gem. Been at this for hours trying to cobble together sending the key to the cloud. (Installed CLI, then DFU was down…, factory reset, then the Photon refused to show up under the USB utility, then again, then dfu was in the wrong directory, then all the base belong to cloud…)

I have been having the same problem as the above post before this happened and it did it with every single device. Every single one showed up, but would not Tinker or Build flash…

I am stuck trying to dump my key right now, it looks like it isn’t liking openSSL. I grabbed the utility and followed the thread on installing all the goodies… Is there some way to manually run the command that is failing?


#49

Make sure you install OpenSSL on Windows: http://slproweb.com/products/Win32OpenSSL.html
Win32 OpenSSL v1.0.2d Light should work.

When you run the keys save command, you have to delete the previous file there because it will not overwrite it by default. See how it’s saying the file already exists, add the --force flag? You can specify the force flag or just create a new name or delete the previous files. Here’s a run through:

✶brett✶ ~/code/firmware/modules $ particle keys save mykey
running dfu-util -l
Found DFU device 2b04:d006
running dfu-util -d 2b04:d006 -a 1 -s 34:612 -U mykey.der
running openssl rsa -in mykey.der -inform DER -pubout  -out mykey.pub.pem
Saved!

✶brett✶ ~/code/firmware/modules $ particle keys save mykey1
running dfu-util -l
Found DFU device 2b04:d006
running dfu-util -d 2b04:d006 -a 1 -s 34:612 -U mykey1.der
running openssl rsa -in mykey1.der -inform DER -pubout  -out mykey1.pub.pem
Saved!

✶brett✶ ~/code/firmware/modules $ particle keys save mykey
This file already exists, please specify a different file, or use the --force flag.

✶brett✶ ~/code/firmware/modules $ particle keys save mykey --force
running dfu-util -l
Found DFU device 2b04:d006
running dfu-util -d 2b04:d006 -a 1 -s 34:612 -U mykey.der
running openssl rsa -in mykey.der -inform DER -pubout  -out mykey.pub.pem
Saved!

When you send the keys you use the device id or device name, so something like:
particle keys send myphoton2 mykey.pub.pem
or
particle keys send 123412341234123412341234 mykey.pub.pem


#50

@FlaredElectronics
I am curious. Did all of your devices start mis-behaving at the same time? … That seemed to happen to me, as well.

Let me know if you find a solution. I have successfully ‘saved and sent’ my keys. However, this did not completely solved my problems (as I described above).


#51

Looks like openSSL is being a tool. Installed it 4 times, and registered the environmental variables several times.

Can someone give me the variables to check against just in case?

Also is there a way to manually call the path to openSSL in a command or provide Node.js where the path is?


#52

Yes, but all but the device I am attempting to fix decided to come back a few hours later. It is like this device was the straw the broke the camel’s back. Other than the wait time, spending 5 hours messing with it just isn’t worth 19 dollars. I unsoldered it and removed it from my project (a pain in the…), then had a German keyboard kid style talk with it. Being up 15 hours then having defiant parts isn’t allowed. (Just to be clear, I didn’t damage it)

I bought 2 cores, 7 Photons, and 2 electrons because I figured something like this would happen. I just hope the software engineers have some way to find and reset these keys for larger commercial customers. The process has a few holes in it that needs a bit of documentation updating, but remember support for this product is built into that 19 dollar cost… I don’t think I have the right to complain to much there…


#53

@FlaredElectronics
I ‘think’ I might have soled my problem. My Photons were part of a ‘product’ that was scheduled for automatic OTA firmware flashes. And for whatever reason, this was messing things up. (Maybe my firmware was ‘bad’)


#54

How did you fix that? Did you go into “yellow mode”? I got all mine but the one to work now with a simple factory reset.


#55

Yellow blinking is DFU mode - https://docs.particle.io/guide/getting-started/modes/photon/#dfu-mode-device-firmware-upgrade-


#56

I finally compiled a ‘good’ firmware and uploaded it to my Dashboard… If only one of your devices is having a problem, then your issue is probably different than mine.

Also, I have had a better experience working with the recent v0.4.4 firmware release.


#57

Sorry, now it is to late :wink:
My Photon was rescued by this thread (fast blinking cyan with very short flashes of red in between, later then only fast cyan)
I tried a lot, including firmware-reset, create new key … but after

dfu-util -d 2b04:d006 -a 1 -s 2082 -D ./Downloads/cloud_public.der

all works perfect.

How did i get into the Problem ?
My photon worked out of the box. I claimed it. did a few tests with tinker. …
Days later i assembled the photon and adjusted the Voltage … In this process i had the photon multiple times connected and disconnected to power. I wondered why the photon did blink in some unusual colors, but i couldn´t undo the power-off.
So i think in my case the reason was an interrupted auto-update.


#58

Hi mdma - I have the rapid cyan, looks like will connect - then short red flash problem too,
I tried Dave’s solution to do a “particle keys send DEVICE_ID KEY_FILE”

I got;
C:\Users\CHRIS>particle keys send DEVICE_ID KEY_FILE
Couldn’t find KEY_FILE.pub.pem

I tried your suggestion “particle keys new” and got this response on the terminal

C:\Users\CHRIS>particle keys new
running openssl genrsa -out device.pem 1024
Error creating keys… Error: Command failed: ‘openssl’ is not recognized as an
internal or external command,
operable program or batch file.

Any idea what I’m doing wrong here?


#59

I guess you don’t have openssl installed? You’ll need to install that on Windows first.


#60

Yes, that was my first thought - but definately installed - and re-installed. Sorry, should have pointed that out. And, the Particle CLI works in all other respects