Experience sharing: Getting Photon to work with Asus RT-N12E

Hi everyone,

Today I’ve had quite some trouble getting my Photon’s to connect to an Asus RT-N12E Wireless-N300 router. I wanted to share what worked, so that hopefully others won’t have so many problems in the future.
I’ve found other people having trouble with Asus routers:

In the end, I got it working after multiple tries over the course of a few hours.
I’m not sure that all of these steps were necessary, but who knows…

  • removed a “_” from the SSID
  • switched “wireless mode” to legacy under “wireless” settings
  • disable “b/g protection”
  • used WPA2 password, without “_”
  • erase all the saved WiFi settings from the Photon, by holding the setup-button for 10 seconds. (as per wifi troubleshooting guide, step 3)
  • enter the new credentials via serial:
    1. reboot the Photon in “safe” mode (hold “setup” button, reset, wait until blinking purple, release “setup”)
    2. wait until photon fully booted
    3. hold “Setup” button again, until it blinks dark blue (“listening mode”)
    4. use command line particle serial wifi
    5. scan for wifi networks
    6. choose wpa2 security
    7. enter wifi password
    8. leave it alone for several minutes, blinking green, until it suddenly “clicks”, and connects, breathing green. (Router isn’t connected to internet, so doesn’t progress to cloud-connection)
      (I had to retry the steps above quite a few times)

After it “clicks” the first time, reconnects after a powerdown of the Photon seem to be faster.
Powering down the router and retrying takes longer again. (Observation: the status LED blinks green, and after a few green blinks, 5-10 seconds, blinks white-ish once, and then continues blinking green. This cycle repeats multiple times before it succesfully (re)connects

Combinations that definitely DIDN’T work:

  • SSID with “_”, using no encryption at all, with “wireless mode” set to automatic
  • SSID with “_”, using WPA2 encryption
  • SSID without “_”, wireless mode legacy, “b/g protection” enabled.

This post is mostly intended for documentation, in hopes of helping others save time.
Feedback / experience sharing is welcomed though!

1 Like

Did you turn the 5 Ghz network on or off? If it was on during your tests try to turn it off and see if your connection problems are solved :slight_smile:

This is a fairly cheap model, intended for projects on the road, it doesn’t have a 5GHz :slight_smile:

Sorry, I have googled your model and the product description said it has 5 Ghz :smile:

Oh really? It’s this one
Where did you find it has 5GHz, now I’m curious!
In any case, I just double-checked, and didn’t find a setting for it in the wireless menu of the admin screen. Thanks for the tip anyway!

P.S. I’m continuing to struggle with this thing… Once the connection is made, reconnection is fairly quick, but after a power-down (not just a reset) of either the router or a photon, it takes variously long to reconnect.
Since this is intend for a band’s stage show, where quick set-up is a high priority, this is a problem…

If anyone else has tips or suggestions what I could change, I’d be happy to hear them! :slight_smile: