Photon takes long time to connect to ASUS router

I’ve got a new photon that struggles to connect to my wifi. It seems like it might be an issue with my router or something, and not with the photon, because it is able to connect to a hotspot from my phone no problem. Here’s what I’ve been seeing and what I’ve tried:

  • Brand new, out of the box photon

  • I’ve tried using the iOS app to connect to it, and the CLI. Both have worked before, but very inconsistently. Maybe after 20 tries of resetting the photon it will connect, or if I leave it for maybe 10 minutes as it tries to connect it will connect.

  • It seems to connect much faster just after I restart my router. It will be struggling like normal, unable to connect (blinking green light, sometimes getting to slowly blinking cyan but then back to green, sometimes with a couple yellow blinks in between), then I’ll restart my router, and the photon will connect pretty much right away.

  • I changed my wifi SSID so it has no spaces

  • I have a dual band router, but each band has a unique SSID

  • Tried setting a static IP for my photon. I set the static IP in my router’s interface (, as well as on my photon via the ‘photon doctor’ command in the CLI. I set the start of the router’s DHCP pool to After doing this, when I power on the photon, it quickly goes from blinking green to slowly blinking cyan, but never goes to quickly blinking cyan. It eventually blinks yellow twice then goes back to green and repeats. This cycle takes 20 seconds or so.

  • When setting the static IP, in the Particle Doctor script in the CLI, I set the default gateway and DNS Server to, which is the IP of my router

  • I’ve had these same issues on this wifi network with other photons

  • As mentioned above, my router uses the IP pool, rather than Could this be a problem?

  • My router is an ASUS RT-AC1200

  • Wifi authentication method is WPA2-Personal and WPA encryption is AES

  • After the photon connects once, I can disconnect it and immediately reconnect it and it’ll connect quickly. If I leave it sit for a long time though, it’ll take a long time to connect.

Does anyone know any router or photon settings that might be causing an issue like this? What does slowly blinking Cyan mean? Thanks in advance.

I had a similar problem using an ASUS router. One of two things fixed it. I forced a static IP in the router for the Photon. I saw the router assigning an IP for the Photon repeatedly in the logs. I also disabled the roaming assistant which is under wireless settings/professional.

It doesn’t look like my router has roaming assistant, it’s not in the professional menu (it’s actually an element on the page, but it’s not displayed, and it I un-hide it and try to disable it the page just reloads, so I’m pretty sure it’s just not an option on my router).

I did set that static IP now, and I’ve actually got the photon set to dynamic IP. I’ll also note to anyone reading this that I have my IP pool on my router set to start above the IP it’s assigning to my photon. Pool starts at, but router sets photon to

Also worth noting that after the photon connects once, I can disconnect it and immediately reconnect it and it’ll connect quickly. If I leave it sit for a long time though, it’ll take a long time to connect. I’ll add this to the original post as well.

@jstobaugh, any other insight into any other “professional” settings in the router?

Another curious thing I just witnessed:

  • I plugged in my photon after being powered off for a while–it was sitting for a while at the blinking green stage like I had been seeing.
  • I then rebooted my router via the web interface, and right as I did so, the photon went from blinking green to slow blinking Cyan (as opposed to the rapid blinking when it’s about to connect successfully).
  • Then as the router powered off, the photon went back to blinking green.
  • When the router powered back on though, the photon powered up pretty much right after the router came back online. It went from blinking green to slow cyan to fast cyan, then it actually blinked yellow twice, then back to flashing cyan to breathing cyan, and it was connected. Then again, if I were to disconnect and connect immediately, it would connect quickly again.

Not sure if this tells us anything? It’s seeming more and more to me like this is something weird with how ASUS’s router firmware interacts with the photon trying to establish a connection. I have very little experience with this though so I don’t know what the issue could be.

It’s almost like the connection attempt needs to fail first, then when it tries again it’ll work. Not sure if it’s an issue on the router side or photon side.

Note, right now I’ve got my wireless mode set to legacy for the 2.4 GHz band, per the post here

The AP isolated is the roaming assistant and you have it disabled. You don’t state what OS you are running. I found 6.3 to be the most stable or 1.01(Latest).

The time it takes for the photon to go from blinking green to slow blinking cyan can vary depending on how many wifi credentials stored in it. You may reset all credentials by holding mode button for 10 seconds until it flashed blue. Now put in your credentials for your wifi just once. Slow blinking cyan means it is connected to the router and to Particle. I am using a different subnet than 198.168.1 with no problems.

1 Like