Photon can't connect to WiFi extender

I originally setup my photons on a Linksys AC1200 router but the signal wasn’t strong enough so I bought a Linksys AC1200 WiFi Range extender and now my Photons will no connect. I tried setting the SSID on the extender different from that of the router and I tried it the same but the Photon will not connect. I read one forum discussing extenders that said he completely reset the Photon and then it connected but I used one right out of the box and it still didn’t work. Any thoughts? I know the extender service is good because I easily connect my cell to it. Also the extender is providing 2.4GHz because I know that is all that’s compatible with the photon.

Is the photon not able to connect to WiFi or is it not able to connect to the Particle cloud? What is the color sequence?

Sorry, this is not direct answer to your question…

Instead of using a repeater, maybe you can try to add antenna. I have these installed on my 3 photons and I have good results so far. They are cheap too.


Did you use Android app to connect to the wifi?
And I also read that Photon has problem with 40mhz and 20mhz wifi.


As I’m going through the setup procedure it flashes between green and orange. It keeps failing saying “Setup process failed at claiming your device, if you Particle device LED is blinking blue or green that means you provided wrong Wi-Fi credentials, please try setup process again.” I know the WiFi is correct. I can’t even set it up sitting right next to the router now. Did I do something when I tried to change the internet connection?

I’ll have to order some but I need an immediate solution for now.

It has to be something wrong with my wifi connection. I had set these photons up just fine at my desk when I had my company ethernet cable plugged into the router. Now I am at a customer site and have their ethernet cable plugged into my router and I can not get any photons to connect, none of the four previously connected or a brand new photon out of the box. Any ideas on router credentials that might have changed that could be causing this?

We had a problem like this in the past where the company’s main WiFi routers had a special mode to block “rogue” WiFi connections. It did this by listening for new AP SSIDs and then immediately creating a network with the same SSID to hijack the connection. I would ask your customer about their setup to be sure.

1 Like

I think that might be the issue, I have them contacting IT right now to get me set up. Thank you

Did you try getting the Photon connected to WiFi using particle-cli?

# Put Photon in listening mode first
particle serial wifi

… isn’t that technically illegal?

“…shall not intentionally generate harmful interference…”

Not when @bko does it


Can you provide a link to the specific antenna that is working with your photons? I’m having trouble connecting to my wifi on my photon when I’m in the room next to the modem. Connects to the cloud fine when I’m within a few feet of the modem though…

I am in SE Asia so where I bought them (around USD 1.5) might not be available to you.
Try to google “ipex ipx wifi antenna” or similar.

Here are some links:

Since it is cheap, I always use it no matter how far/near my photon to my AP.

Here is a link to the Cisco configuration guide for one such router:

1 Like