Photon can't connect to SSID with "&"


#1

Just checking other people have this same problem or not…

I have 2 photons and both photons cannot connect to SSID that has “&” character (such as ET&JDS). Deleting the & from the SSID will solve the problem.

The photons can scan/read the SSID name. But when trying to connect to the wifi (via Particle mobile app), it will fail (not breathing cyan).

Is this a known bug? I tested it on 2 Photons and 2 different access points / router (TP-LINK and EDIMAX).

Thanks


Photon can't connect to WiFi extender
#2

Nope, I can’t reproduce that.
I have SSID trial&error and my Photon connects just fine.

What system version have you got on your device?
What encryption are you using with your network?
How did you try to set the WiFi credentials?


Update:
I’ve now also tried ET&JDS and unsurprisingly it also worked.


#3

Both photons are using 0.7.0.
Wifi security is WPA2 - AES.
My laptop, Android and iPhone can connect to this wifi just fine.

My AP is TP-LINK with dd-wrt installed. Second AP is Edimax with original firmware.
First I thought it was because the dd-wrt problem, so I changed to 2nd AP and still can’t connect.

I used Particle app on Android to claim the Photons and then set the wifi credentials with that Particle app. It failed at the last step, not breathing cyan.

Anyway, since you can’t reproduce this problem and I can just easily change my SSID, I will just “ignore” this problem :slight_smile:


#4

Can you try to set the credentials via particle serial wifi?

It might well be that this is not a problem with the Photon but the Android App.


#5

So I set up my TP-LINK with dd-wrt Firmware: DD-WRT v3.0-r36247 std (06/29/18) to have 4 SSIDs:

  • ETJDS
  • anotherETJDS
  • ET&JDS
  • Trial&Error

All are using WPA2-AES with same password (8 digit number)

My photon can connect to ETJDS and anotherETJDS.
But it won’t connect to ET&JDS and Trial&Error.
I cleared out the Photon wifi credentials by holding the setup button for 10 secs before trying to change the SSID. And yes, I am still using the Android app to claim/connect the Photon.

I don’t have my laptop with me right now. And my desktop PC can’t do “particle serial wifi” since it doesn’t have wifi card.


#6

I think you are supposed to do particle serial wifi with the Photon connected via USB. Does it even matter that the PC doesn’t have wifi since you are only using the PC to tell the Photon how to connect? My PC doesn’t have wifi but I use it all the time for Particle development… I do recall running particle serial wifi but I don’t have my Photon connected at the moment. As @ScruffR stated, it is probably a shortcoming of the Android app that it doesn’t accept the special character.


#7

I tried to do a particle serial wifi (with administrator right) from command prompt (windows 10) and it won’t let me. It has below error message:

particle serial wifi
? Should I scan for nearby Wi-Fi networks? Yes
Error configuring Wi-Fi: Unable to scan for Wi-Fi networks. Do you have permission to do that on this system?

The photon is connected via USB cable. I can do “particle serial monitor”.


#8

deleted


#9

If you answer the question ? Should I scan for nearby Wi-Fi networks? with No you can enter the SSID yourself.


#10

You are correct. Using particle serial wifi, I can connect to ET&JDS.

It looks like the Android app is the problem.


#11

I have filed an issue with the Android App repo