Photon problems (not working)


I have recently bought a Photon and it causes only trouble.

  1. I cannot set it up properly (it stucks at “Setting up cloud connection”)
  2. The Wifi Range is only two meters
  3. Sometimes I can flash code OTA but often it gives me “flash unsuccesful” but it begins to flash mangenta.
  4. I can use webhooks (they are working fine) and I can also see that it breathes cyan but OTA isn’t working

Do you know why this happens. Maybe an external antenna? I don’t want to spend money if it’s usless.

I have tried to update it, clear Wifi credentials etc but no success. I’am disappointed.

Another thing which I oberserved: Sometimes the particle resets itself (Thinker)

I have used Photons at tens of meters… I don’t think it is a Photon problem (unless the unit is faulty). Perhaps the issue is environment or circuit build. Can you post a picture of your setup?

These statements seem to conflict as well:

So which is it? If you can’t get past the setup then how can you OTA flash? What is the program currently running on the Photon? Can you share the code? What is your Wi-Fi environment like? (router?, number of clients?, encryption scheme?, etc?) How are you running setup? On the mobile app or CLI? Using CLI, what is the output of particle serial inspect?

1 Like

I can confirm that it isn’t a problem with the environment, I have tested it inside and outside with my router and my two mobile phones as access points, always the same result: no connection possible after 3 meters.

Both statements are true (the setup finishes never but the Photon is indicating that it’s connected to the cloud and it’s also linked to my account. But I m still often unable to flash my code over OTA (f.e blink code). Sometimes it falls back to Thinker (like a reset)

Okay, so assuming it’s not a Wi-Fi problem can you confirm your circuit build? Is a photon in a breadboard? Is there any external circuitry attached? The more information you can give, the better. And don’t forget a picture is worth a thousand words.

It’s a normal photon with headers. I have a bme280 sensor connected to it but the problem with no cloud connection was already there when I tried to set it up for the first time (without sensor). Do you need a picture of the photon?