Device Transfer Requested, Receive Email if transfer is approved or denied? Verifying Product Ownership issues?


This is my first time using Photon and reaching out to the particle community. I attended an IoT workshop and received a slightly used Photon from the instructor, who used that Photon to guide us through the workshop. I have spent the last 2-3 hours trying to have Photon connect to an unsecured Wi-Fi network at school to test out the device. I initially tried using the particle app, and everything appeared to be fine until it failed at “Verifying Product Ownership”… I am using Windows and an Android device.

So I tried doing what Corey @ Particle suggested in the following thread: Photon Setup Failed at "Verify Product Ownership"

I updated to the newest firmware release 0.5.1 following the Particle CLI (easy method) instructions shown in this link:
I then try reconnecting the device to the Wi-Fi network using the particle app but I would still get the same error with Verifying Product Ownership…

Next I try this method posted on: Will not complete setup via app [SOLVED]
particle login
particle identify
particle serial wifi
particle device add [ID] (where ID is replaced with the device ID shown when entering particle identify in cmd)

After running particle device add [ID], it states:
“That device belongs to someone else. Would you like to request a transfer?” I choose Yes.

Then it states: “Transfer #(a bunch of numbers) requested. You will receive an email if your transfer is approved or denied.”

In both situations, failure to connecting the device to a WiFi network seems to revolve around transferring/verifying ownership of the product.

Any suggestions or alternative methods on how I can try to get Photon working to breathing cyan? Or is this as far as I can go until I receive an email regarding whether the transfer is approved or not? When should I expect an email? Who exactly am I expecting an email from??

Any help would be appreciated. Thanks!

Might this network have a captive portal/landing page?
If so, then this is more likely the reason for your problem.

Try connecting to another WiFi - e.g. use your phone as hotspot.

The public school network does go to a portal/landing page to ensure the user of the network agrees to the terms of services. I tried your suggestion of creating a mobile hotspot using my phone. I attempt the same steps I previously stated by entering the following commands in cmd:

particle serial wifi

It is able to detect the Mobile hotspot network, and I input the password and it states: "Done! Your device should now restart."
Next, the device blinks cyan for about 10 seconds. Then blinks yellow about once or twice every once in awhile, then blinks cyan rapidly, and sometimes even blinks green a few times. I’m not sure what that means. No breathing cyan in sight…I’m not sure what’s going on

Captive portals (landing pages) are a big hurdle for Photon. You can search the forum for possible workarounds.

This sounds like what we call an orange burst and has to do with "corrupted" keys on the device.
To repair this try

particle keys doctor <yourDeviceID>


I won’t try to connect to a network that has captive portals. I will continue trying to connect to the mobile hotspot from my phone. I tried the following command after putting the Photon in DFU mode (blinking yellow):

 particle keys doctor <device ID>

And I get the following message:

Found DFU device 2b04:d006
Found DFU device 2b04:d006
Error creating keys… Error: Command failed: C:\WINDOWS\system32\cmd.exe /s /c “openssl genrsa -out 3d0039000947353138383138_rsa_new.pem 1024”
‘openssl’ is not recognized as an internal or external command,
operable program or batch file.

Make sure your device is in DFU mode (blinking yellow), and that your computer is online.
Error - Error: Command failed: C:\WINDOWS\system32\cmd.exe /s /c “openssl genrsa -out 3d0039000947353138383138_rsa_new.pem 1024”
‘openssl’ is not recognized as an internal or external command,
operable program or batch file.

It looks like the DFU device was found but then it encounters an error creating keys. You also mention the possibility of having “corrupted” keys on the device. What are the keys on the device you’re referring to? How do I obtain non-corrupted keys or non-errors creating keys?

That error indicates that you are missing OpenSSL on your machine.
You need to install it and add it to your PATH.

These keys are used to encrypt the communication between your device and the cloud and the command I gave you above would repair these on your device.

Have a look here, this should also talk about OpenSSL

1 Like