Photon Setup Failed at "Verify Product Ownership"

@Jangie how long is your WEP password?

10 characters of hex.

Hmmm… Hex? Should it be alphanumerical somehow? Does other devices connect well under that setting?

I got two photon, one photo works well, but other one don’t.

particle keys new
running openssl genrsa -out device.pem 1024
running openssl rsa -in device.pem -pubout -out device.pub.pem
running openssl rsa -in device.pem -outform DER -out device.der
New Key Created!

and next

particle keys load device.der
running dfu-util -l
Found DFU device 2b04:d006
Apparently I didn’t find a DFU device? util said dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Found DFU: [2b04:d006] ver=0200, devnum=3, cfg=1, intf=0, alt=1, name="@DCT Flash /0x00000000/01016Kg", serial=“00000000010C"
Found DFU: [2b04:d006] ver=0200, devnum=3, cfg=1, intf=0, alt=0, name=”@Internal Flash /0x08000000/03
016Ka,01016Kg,01064Kg,07*128Kg", serial=“00000000010C”

running dfu-util -l
Found DFU device 2b04:d006
Apparently I didn’t find a DFU device? util said dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Found DFU: [2b04:d006] ver=0200, devnum=3, cfg=1, intf=0, alt=1, name="@DCT Flash /0x00000000/01016Kg", serial=“00000000010C"
Found DFU: [2b04:d006] ver=0200, devnum=3, cfg=1, intf=0, alt=0, name=”@Internal Flash /0x08000000/03
016Ka,01016Kg,01064Kg,07*128Kg", serial=“00000000010C”

running dfu-util -d 2b04:d006 -a 1 -s 34:612 -U pre_device.der
running openssl rsa -in pre_device.der -inform DER -pubout -out pre_device.pub.pem
Error saving key from device… Error: Command failed: unable to load Private Key

I got a Private Key error, but try next,

particle keys send [device_id] device.pub.pem
attempting to add a new public key for device [device_id]
submitPublicKey got error: invalid_token

I update firmware 0.4.2 local dfu mode, but don’t work. What’s should I do next? any Idea?

thank you.

It’s all alphanumeric, 0-9, A-F. Works just fine on everything else.

I’m going to try WPA2 tonight to see if that does the trick, but would have preferred not to change my existing setup just for a device.

I have received a further 4 Photons today. Just tried the first one and I get the same issues - fails at the last step of the app based setup.
Clearly an issue with my network (that I do not see with the Core’s). I sent a support ticket on Sunday to ask if someone could Skype me to walk through this, with no response so far. I now have 14 Photons and some customer orders with no workable chips, so keen to get to the bottom of this, though a little disappointed as the Core did not work in some places and I deferred for the Photons, but looks like I am in the same situation.

I really need some Spark support here.

Thank you

Hey Kevin,
Just saw your ticket on Zendesk. I’ve read this thread as you’ve been posting and it seems as if you’ve tried a lot of different solutions. However, there are some common steps that yield great results such as:

  1. Logout of the app and close the app. Then try reconnecting (longer explanation of why can be given if you’re interested).

  2. If step 1 doesn’t do the trick, then make sure you’re updated to our newest firmware release. Photon Firmware Update

  3. I’ll keep your ticket open with me and we will figure it out together! :slight_smile:

-Corey @ Particle

Success!!!

I have loaded up the latest firmware and I can now successfully use the app to run setup on one of the previously failing devices. I will work through more devices (1 down, 13 to go!) - so Corey please keep this ticket open for another day or so and I will report back. Thank you for your help here - very much appreciated.

@Corey - can you provide an explanation of why logout/login might have worked as I want to know what happens to the user credentials when you use the app. I will have a separate question as to what happens when this is an end user who probably does not want a Photon linked to him/herself.

1 Like

just now trying the three photons i’ve received and the first one is causing everything seen here. Very, very disappointed to receive a unit like this…

EDIT: I’m using an Airport Extreme for my main router. I also have several Airport Express on the network, setting one of those to create its own wireless (2.4ghz only) allowed the photon to connect correctly.

@danmanstx, sorry for the user experience but i’m happy you got it working.

The Broadcom chip should be more robust since it is widely used in devices like the Nest.

Can you provide more information about the network settings that is not working?

I was using the iOS Particle app to set up the new photon and it was failing at ‘verifying product ownership’. I tried it a few times, before finding this thread and then trying the new network.

First network Airport Extreme – Dual 802.11n 5ghz and 2.4ghz with a WPA2 password

network i could connect to was older Airport Express 80211n can only pick one so i chose 2.4ghz.

Also worth noting at the core does fine connecting to either but runs in 802.11g.

@danmanstx, i know that for iOS, they prefer to go to the 5Ghz network whenever possible so that is the reason as the Photon might have been programmed with the 5Ghz wifi credentials instead.

Were you prompted to enter the wifi credentials? sorry but i don’t have the iOS app :wink:

yep exactly,

  1. First, you select Core or Photon
  2. Reconnect your phone’s wifi to photon’s self created wifi will be something like Photon-XXXX
  3. Next it’ll ask you to select your wifi
  4. Enter Proper credentials
  5. Runs thru a series of steps of connecting, transferring credentials, connecting to wifi, connecting to internet, then ‘Verifying Product Ownership’ with the particle cloud and this is where it was failing.

After failing it would stay a solid green.

So i’m guessing on the original network settings, there’s 2 SSID, one for 5Ghz and one for 2.4Ghz?

1 Like

It only appears as one SSID to my phone and when i was selecting it from the particle app. I would think that yes, there are two band running just with the same SSID and it connects to which ever one it can. Here’s some info from apple that may or may not be helpful

Simultaneous dual-band support.
AirPort Extreme features simultaneous dual-band 802.11ac Wi‑Fi. That means it transmits at both the 2.4GHz and 5GHz frequencies at the same time. So no matter which band your wireless devices use, they’ll automatically connect to the best available band for the fastest possible performance.

Yeah that’s true… Have you tried using other 2.4Ghz only device with the Airport extreme router? Just trying to get to the bottom of this issue. Thanks for help! :smiley:

I have a roku LT that connects to it just fine and it only supports a/g/n at 2.4ghz. I’ll be sure to try the other photons on the airport extreme and report back if it is a consistent problem. Hopefully do that tonight, ran into some issues with using an interrupt on D0 so i didn’t get to setting everything up last night.

1 Like

There’s some interrupt issue right now that has been fixed but not available yet :wink:

Hi Corey. I have now setup a number of photons and happy that this fix has worked.

2 Likes

Hey Kevin,

Thanks for letting me know this, as it it is helpful for us going forward. Also, I haven’t forgotten about the longer explanation about why logout/login step works. That will come soon! :smile:

-Corey