Boron gets stuck in mobile set up

I have a Boron 2/3G and a Boron LTE which are both stuck in listening mode. I’ve gone through every posted discussion and tried most everything.

Where I get stuck is the Particle App Set up Screen choosing a mesh network.

After I scan the QR code, make sure the battery and antenna are attached and hit next I get the “Do you want to use this Boron ins a mesh network”

I choose no.

Paticle symbol spins and goes back to the “Do you want to use this Boron ins a mesh network” screen and NEITHER button does anything.

I’ve powered on/off the Boron/Computer/phone. Uninstalled/resinstalled the app. Flashed the latest 1.1.0 Device OS using DFU mode successfully, flashed my own firmware, and Tinker using the CLI. I get a “success” message but nothing but blinking blue listening mode.

Device will not enter safe mode. Goes back into listening mode. I’ve tried doing a factory reset. I’ve tried removing the device and sim from my account (success). Now I can’t see the device on Particle console, app, or Web IDE.

Even though it is in blinking blue it will not connect with the CLI.

Ideas? I’d like to get these back on-line to deploy instead of putting them in the trash.

Can you take a look here
Unable to add Boron from CLI/Mobile - Troubleshooting - Particle

When you flash the latest device OS, also flash the bootloader as well

The instructions for that are provided in the link above

Note too the success is using the app on iOS but not Android (at least in my case)

Hope this helps