Unable to add Boron from CLI/Mobile

I have two borons from the initial sale

I try to add these from the App, I get stuck on this screen same as this Boron gets stuck in mobile set up

It spins the first time I say “No” or “Yes” for a few seconds, I hear the device switch modes based on windows new device plugged in, then the buttons do nothing. Repeating the process is always “Paired successfully…Do you want to use this Boron in a mesh network loop”

(the above has no replies from support by the way…)

This is after the mobile app updates the firmware on the device

I try to add the boron through the CLI

Something wrong with the firmware?

I have tried flashing

boron-bootloader@1.1.1 <-- doesn’t even flash, “Unknown module function 2”
boron-system-part1@1.1.1 <- Red SOS, 10 flashes
boron-tinker@1.1.1 <- Red SOS 10 flashes
bootloader-0.9.0-boron.bin <-- doesn’t even flash, 'Unknown module function 2"
hybrid-0.9.0-boron.bin <- Red SOS, 10 flashes

particle update gets rid of the red SOS flashes, same behavior as beginning

Pretty frustrating from a business R&D point of view…

The bootloader should be flashed in listening mode over Serial. What exact commands were you using (Screenshot)?

After that you should be able to flash the system firmware and Tinker in DFU mode.

Thank you Moors7 for your reply, I really appreciate it

The CLI won’t let me flash a bootloader if it isn’t in DFU mode

I put the device into DFU

I do the process above with tinker 1.1.1 instead of system1 and the same results happen

I have also tried the putting in a firmware for a “factory reset” according to this https://docs.particle.io/tutorials/device-os/led/boron/#firmware-reset
(picture removed due to limit)

PS X:\Downloads\p> dfu-util -d 2b04:d00c -a 2 -s 0x80200000 -D .\boron-tinker@1.1.1.bin
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Opening DFU capable USB device...
ID 2b04:d00d
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #2 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "External Flash   "
Downloading to address = 0x80200000, size = 11580
Download        [=========================] 100%        11580 bytes
Download done.
File downloaded successfully

I do the factory reset (hold from magenta-yellow-white) same behavior (both with the app and CLI)

I have two borons and the behavior is identical on both devices

For flashing the bootloader, you want to use listening mode, with --serial as opposed to --usb. That should help. Give it a shot?

Excellent, the bootloader loads correctly with the --serial

Glad that’s taken care off, thank you Moors7!

The issue that remains is I am unable to claim the device in CLI or the mobile app

With clean firmware upgrades, the ‘cant move past “do you want to use mesh”’ issues remains

in listening mode (blue flashing)

PS X:\Downloads\p> particle identify -v
Serial timed out
VError: Serial timed out
    at whatSerialPortDidYouMean.then.then.catch.err (C:\Users\Dan\AppData\Local\particle\node_modules\particle-cli\dist\cmd\serial.js:321:13)
    at <anonymous>
    at process._tickCallback (internal/process/next_tick.js:189:7)

Looks like it doesn’t know what COM port to connect to?

My boron is on COM26 serial

PS X:\Downloads\p> particle identify --port COM26 -v
Serial timed out
VError: Serial timed out
    at whatSerialPortDidYouMean.then.then.catch.err (C:\Users\Dan\AppData\Local\particle\node_modules\particle-cli\dist\cmd\serial.js:321:13)
    at <anonymous>
    at process._tickCallback (internal/process/next_tick.js:189:7)

This is all in listening mode, should I be in a different mode for this?


I am still unable to claim the devices with the CLI

I tried using my tablet (iPad) instead of my phone (Android)

With the iPad, the app does not hang up at the mesh screen

Not really a solution I know, but hopefully it helps others

Thanks Moors7 for your assistance

Thanks @frustrateddan,

Yes I have tried this. I don’t own any apple devices so have not been able to try. Perhaps its a Android problem then.

I haven’t gotten any responses besides you to my other post (stuck in mobile set up). Frustrating after spending quite a bit of research funds on Particle products… .