Boron stucked in DFU-ish mode and unable to get into listening mode

I need to link again my boron to my account in order to configure a third-party SIM card. I tried to put the device in DFU mode to flash the device OS (tinker) but now it doesn’t seem to respond to any commands.

RGB is currently blinking yellow and CHG is rapidly blinking red. It does not let me enter listening mode nor safe mode.

I get this error when trying to flash tinker with the CLI:

c:\Users\Desarrollo\Downloads>particle flash --usb hybrid-0.9.0-boron.bin
Error writing firmware: Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Cannot open DFU device 2b04:d00d
Error during special command “ERASE_PAGE” get_status

If somebody knows how to force a factory restore, or to get it to listen mode so I can get the device ID and add it again to my account it would be much appreciated.

Regards.

I’d try downloading system-part1 and flash this way (maybe even 1.1.0-rc.1)

particle flash --usb <yourSystemPart1.bin> -v
particle flash --usb tinker -v

I was a bit confused because of CHG rapidly blinking and not responding to Mode button, but this worked.

Thanks a lot!