Unable to get Boron LTE into DFU or listening mode

A Boron LTE came back from the field after many months of operation with an “Assertion Failure” error (SOS + 10 red flashes). I cannot get this device into DFU or Listening mode. It just alternates between flashing red for ~10s, followed by solid white for ~20s. I’ve tried holding the mode button down, turning power on and holding for 20s but I cannot force it into factory reset either. Is there a way to force it into DFU mode so I can try to recover this device?

The normal way to invoke DFU is to hold down MODE, tap RESET, and continue to hold down MODE while the LED blinks magenta (blue and red at the same time) until it blinks yellow, then release. Does it do any of that sequence?

No, holding down the mode button does nothing. The device just continues to flash red (SOS + 10 flashes) for ~10s and then solid white for ~20s, then back to red. No other combination of button presses and power cycling has made it change this pattern so far. This particular device was first provisioned 17-Mar-21, so not terribly old. No signs of environmental or physical damage.

@Acrop ,

There are a couple other methods that could work.

  1. You can use the DFU over USB tool to restore the deviceOS and firmware:

https://docs.particle.io/tools/device-programming/device-restore-usb/

  1. You can use the Particle Command Line Tools to put the device into DFU mode and flash Tinker from there:
particle usb dfu
particle flash --usb tinker

Hope one of these works for you.

Chip

Thanks for the suggestions Chip! No success yet, but I may be missing something. In option 1, I don’t actually see a link to the web page for “DEVICE RESTORE OVER USB”, or is the web page supposed to pop up as soon as I connect the usb cable to the powered device? My computer isn’t registering any usb devices as the LTE is not in serial or DFU mode.
Same with option 2, I get “No devices found”, because the LTE is not in serial or DFU mode. My Windows drivers and usb cable are ok because as soon as I attach a working LTE, the drivers load instantly. What am I missing?

@Acrop ,

Right, I guess that is the chicken and egg issue here. It sounds like you have attempted all the right steps but just to make sure, this is what is typically seen

On the DFU over USB tool, you should see this when you click the “select device” button:
Screen Shot 2021-11-12 at 10.41.18 AM

Then you should see something like this (need to use a supported browser):

Since these did not work, do you happen to have a Particle debugger?

Also, since you have attempted all the right steps, you can open a ticket with service and ask for a replacement device.

Thanks,

Chip

Thanks Chip. No I don’t have a Particle debugger, but I might look at buying one.

1 Like

My Particle debugger finally arrived. Unfortunately it doesn’t help either. I first tried using the drag-and-drop method of uploading a new OS hex file as per instructions here. I upgraded the debugger firmware first as instructed. It seemed to upload the hex file ok and the red flashing stopped while uploading, but as soon as the upload was finished, the red flashing started again. No hex file was visible in the DAPLINK drive. I tried this several times. Next I tried the OpenOCD (via Particle Workbench) method. It also didn’t work. Error: “No DFU capable USB device available”. I can see it tries to put the device into DFU mode, but ultimately fails. So I think I have come to the end of the road on this device. Unless there is a way to force it into DFU mode, there is no other means to restore it. Does anyone have any other ideas?

@Acrop,

Oh man, you really have went through all the steps. Couple thoughts:

  1. Do you have another Particle 3rd Gen device to try out your new debugger on? That really would eliminate any other possibilities.

  2. Have you contacted support? They may be able to help you find a solution.

Good luck,

Chip

Just tried the debugger on a new Boron LTE and it works great! Even in drag-and-drop mode, you don’t need to set it in DFU mode first. It does it by itself. A very handy tool for setting up lots of them! Unfortunately there is no support for us Down Under for the LTE. I’ve been living in hope for a few years now thinking that support will be extended soon, but no luck. I think Particle have given up which is a pity because the LTE version works sooo much better than the 2G/3G version.