Unable to set up Boron LTE

The connecting to bluetooth from the phone settings appears to have been a red herring. I tried to make a video of what I did previously but couldn’t replicate it. I was finally able to connect and complete the setup after several tries though. A couple times waiting 5+ minutes to see if it would connect, but after that, waiting no more than about a minute before retrying.

I am trying to setup my Boron LTE. It is pairing with the iOS app, after the selection of the “Use in Mesh Network” - it fails with a pop up “Something went wrong with Bluetooth”.

I tried with the Particle CLI - following works

particle identify
particle flash usb <hbrid bin file> 

but the following does not

particle setup
particle device add <device id>

was trying out the whole weekend and today too… any suggestions would help me. feel like kind of stuck.

CLI does not support all the commands for Mesh devices yet.

  1. Did you flash the rc25 hybrid bin?
  2. Can you do a particle serial identify to get your sim card information?
  3. Which phone model are you using which is facing Bluetooth issues?

I could walk you through the manual setup and hopefully you are unblocked.

Hello Kenneth,
I did flash the hybrid-0.8.0-rc.25-boron.bin - this worked
I can do a particle serial identify - I get an ID 24 char HEX String
I am using iPhone 7 with iOS ver 12.0.1

yes, any help would be appreciated

Is this a typo or are you really missing the -- in what should be particle flash --usb <hbrid.bin> -v? (I’d always add the -v switch to get a more verbose output)

Hi Scruff,
I was able to flash the bin file… just a typo writing it here on the forum. I used the command as you said
particle flash --usb

But I was not able to claim or continue the setup with the app on iOS


1 Like
  1. Place the Boron in Listening Mode (blinking blue)

  2. run the command:

    $ particle serial identify
    Your device id is 23402384x92380x993js39u93
    Your IMEI is 0987654321
    Your ICCID is 1234567890
    Your system firmware version is 0.8.0-rc.25
  3. Copy the ICCID and go to https://setup.particle.io/

  4. Click on Activate a Particle SIM right at the bottom of the page

  5. Paste the ICCID and hit NEXT

  6. The SIM should be activated

  7. Go to https://console.particle.io/sims and see that the SIM status is Active

  8. Copy the following code and save exit_listening_mode.ino

    #include "dct.h"
    void setup() {
        pinMode(D7, OUTPUT);
        digitalWrite(D7, LOW);
        const uint8_t val = 0x01;
        dct_write_app_data(&val, DCT_SETUP_DONE_OFFSET, 1);
        // This is just so you know the operation is complete
        digitalWrite(D7, HIGH);
    void loop() {
  9. Compile the app for Boron using:

    $ particle compile boron exit_listening_mode.ino --saveTo boron_exit_listening_mode.bin --target 0.8.0-rc.25

  10. Place the device in DFU mode, flash this binary using:

    $ particle flash --usb boron_exit_listening_mode.bin
  11. Hit the RST button and see that D7 LED lights up

  12. Place the Boron in DFU mode

  13. Download tinker-0.8.0-rc.25-boron.bin from https://github.com/particle-iot/firmware/releases/tag/v0.8.0-rc.25-mesh

  14. Do a particle flash --usb tinker-0.8.0-rc.25-boron.bin

  15. Hit RST button and the Boron should blink green and eventually breathing cyan

Sorry for the lengthy steps but I hope this sheds some light on why :particle: spent lots of effort getting the Mobile app + BLE working in the background.

There’s folks who are having issues with BLE and I hope we have that resolved soon to have a smooth onboarding process!

1 Like

Hi Kenneth,
I do not get an ICCID. I only get these two lines,

C:>particle serial identify

Your device id is e00fceXXXXXXXXXXXXXXXXXX
Your system firmware version is 0.8.0-rc.25

C:>particle help
I do not see the IMEI or ICCID … I am using a non-particle SIM card… 2G/3G is fine for the moment

I got the ICCID from my SIM card another way. However, trying to activate it using the way you suggested… says it is an Invalid SIM card. It is not a Particle SIM… it is a 3rd party SIM card.

You cannot activate a 3rd-party SIM card using the mobile apps. You need to follow the instructions in the 3rd-party SIM guide:


@jensck I’m sure you already know this but my device does indeed pair right up using an IOS device (old ipad). I haven’t seen any info regarding a fix for android based devices yet. I noticed the ios app does things in different order than the android app. Probably doesn’t matter, just odd.

There are two things that may help with Android:

  1. Upgrading the device to 0.8.0-rc.26 first will help with pairing issues as well as failures during data communication. This was particularly prevalent with Android 7 devices.

  2. Version 2.3.8 of the Android app was just released to the Play store and should be available in a few hours. It has a debugging log feature that will make debugging these types of failures much easier. (The iOS app has had the debug log for a week or so.)

Hi folks,

Just received my first Boron and am having the same issue: it’s stuck on pairing step. Using USB and particle identify returns “Could not identify device: No serial port identified”.

You won’t be able to particle identify until you’ve upgraded the device the first time.

Follow the instructions here to update the Boron by CLI:

Once you’ve upgraded the Boron to 0.8.0-rc.26 you should be able to pair with most Android devices, and also particle identify will be supported.


Unable to flash with new firmware: No DFU device found. CLI is updated to latest version.

You probably haven’t got a DFU driver installed or your device is not flashing yellow.

Yes, it’s in listening mode flashing yellow. With Electron I can run dfu-util -l and it detects the device. In the Control Panel I see libusbK Devices / Electron DFU Mode. If I connect Boron and put it in listening nothing happens.

Listening Mode would be blinking blue.
Blinkin yellow is DFU Mode.

That is because the libusbK driver was assigned to be applied on Electrons in DFU Mode, but that assignment has obviously not been made for Boron in DFU Mode, so you need to do that.

I found the easiest way to do that in Windows is zadig.


Installing Zadig and registering USB drivers for Boron with it helped. I was able to flash it and then pair and activate it. Thanks!


Success!!! I was able to pair with the Boron after flashing the hybrid-0.8.0-rc.26-boron.bin firmware over USB and verifying that the Nexus 6 was using app version 2.3.8. After pairing, I was able to get through the following steps to set up the cell connection and the mesh network. Thanks to all who helped out with troubleshooting this!