Boron stuck in listening mode and will not pair via the iPhone App


I have Boron + Xenon setup. It has worked perfectly in the past. While debugging an issue on the Xenon, I uploaded a new version of the application and Xenon board lost connection to the Boron (cyan led blinking on Xenon). This has happened to me in the past as well so I just unclaimed the Xenon board and tried to re-pair it again via the App. But that did not solve the issue meaning it did not connect. After much deliberation, I just unclaimed the Boron as well and thought I will just start over. Bad move!

Now, I can put Boron in listen mode (blue led blinking) but it won’t pair with the iPhone App meaning I cannot continue the setup and get the following error:

Error: Unable to find your mesh device. Make sure the mesh device’s LED is blinking blue and is not connected to other devices

I factory rest both Boron and Xenon and see if it is my phone. But, I was able to pair Xenon to my phone but not Boron. So, I don’t think it is my phone.

I have seen other posts, looks like, some have run into this issue in the past and switching phones have helped. So, I tried another iPhone and then an iPad but no luck. I have updated the FW on Boron to the latest version v.1.4.0. Still same issue! Boron cannot be paired but Xenon can. Not sure what is going on?

Any ideas,

Thanks in advance,

Hi Syed,

Indeed, unclaiming a device is to be avoided! :slight_smile:

Would you mind giving this a shot: Specifically, if the Boron is stuck in Listening Mode, you may need to mark its setup flag as done.


I was able to resolve the issue with the help from Particle support.
Basically, had to re-register my devices using the command line option as the UI/smart-phone scenario was not working.


Woo!!! Happy to hear it Syed!