Unable to re-claim a Boron

I somehow managed to get a Boron in a SOS and “Assertion failure” state. I managed to recover it from this state by following the instructions at the bottom of this post:
Boron FW restore. That least got the Boron back into listening mode from where I could do a “particle identify” and “particle update” in the CLI. It now has firmware version 1.4.4 and one of my programs successfully uploaded. But it will still not connect to the cloud. I went through the mobile app to claim the device (eventhough it was already claimed) and it told me just that (already claimed). I then unclaimed the Boron in the console and tried to reclaim it with the mobile app, but now it comes up with an error: “Unable to find your mesh device. Make sure the mesh device’s LED is blinking blue and that it is not connected to any other devices”.
Could it be because I deactivated and released the built-in sim and have been using a 3rd party sim? Any help appreciated to get this back on line!

Hi Acrop,

Separate from the claimed state of the Boron, the mobile app should be able to detect a Boron in listening mode. Have you power cycled your phone too? What type of phone and version of the mobile app are you using?

When you successfully uploaded one of your applications, did you also go reconfigure it to use the 3rd party SIM again?

Yay!! Success!! So, a power cycle of the phone (and a new day?) managed to pair the mobile app with the Boron. It didn’t seem to go through all the usual steps in claiming a device. Instead it came up with an error after pairing: “Setup has encountered an error and cannot continue”. Nevertheless, I do now see my Boron in under Devices in the console. Not sure how? Perhaps the unclaim didn’t actually unclaim? No matter, it works. My program does set the credentials for my 3rd party sim provider but after this step it was still stuck blinking blue. I then followed the steps in your link and, Voila!, it connected to the cloud and I’m in business! Thank you!!