Claiming an unclaimed Boron

I have a boron I was once able to activate and add to my devices.
However, after activation and claiming, I was never able to connect to the cloud again (after a week of attempting to connect to the cloud).
I tried resetting the device completely. I also “unclaimed” it, which I probably shouldn’t have.
I can put in DFU mode and upload different firmware via USB but I am unable to claim the device again through the setup process (on my phone).

I went through a step-by-step process stating to put a 0.8.27 debugging firmware on the device (0.9.0 debugging firmware doesn’t produce any output), when I do this, I can see debug logs but the device is never able to download and update to 0.9.0 - it always fails.

After putting 0.9.0 hybrid firmware on (so no need to update DeviceOS), I get to the Mesh Network setting (to use or not use with a mesh network). It never gets past this point popping up an error saying it needs to reset the modem because there was an issue.

Now, it sits in listening mode perpetually and I’m completely out of ideas on what to do (nor have I found any) to get it back to breathing cyan (which, once I do that - I’m sure I can claim it a myriad of ways).

Anyone with any ideas on what I can do to get my device in working order?

Thanks in advance

You can try these steps

download system-part1 and flash in DFU Mode via

particle flash --usb system-part1-0.9.0-boron.bin -v

Copy this into a file (e.g. dctSet.cpp)

#include "Particle.h"
#include "dct.h"
SYSTEM_MODE(SEMI_AUTOMATIC);

void setup() {
    const uint8_t val = 0x01;
    dct_write_app_data(&val, DCT_SETUP_DONE_OFFSET, 1);
    // This is just so you know the operation is complete
    pinMode(D7, OUTPUT);
    digitalWrite(D7, HIGH);
}

and build that via

particle compile boron dctSet.cpp

and flash the resulting binary in DFU Mode

particle flash --usb firmware.bin -v

and let that code run again once.
After that flash Tinker

particle flash --usb tinker -v

and see if the device can make it to breathing cyan.

Thank you for this!

I was able to make it through and flash tinker however, I can only get as far as blinking green - which is back to where I was originally.

I will email support and see what next steps to take as I do not believe after initial setup (which put tinker on the board), I’ve ever been able to connect to the cloud. I’m not sure what happened to be honest.

Thanks again!

Have you activated the eSIM?
Can you check at console.particle.io/sims?
How long did you leave the Boron blinking green? Try leaving it over night.
Can you try putting the device in Listening Mode (blinking blue) and run a setup via the mobile app again?

I have an almost identical issue to the one described above. My Boron LTE used to work but I now cannot get past the green blinking after leaving it unpowered since mid March.

I can see the device in serial and can put in DFU mode and program. I have

  1. Updated the firmware to the latest
  2. Tried holding mode until rapid blue blink
  3. Checked the antenna
  4. Coverage is good as another Boron LTE photon connects fine
  5. Tried Key and Device Doctors
  6. The SIM is active (but no longer linked as I unlinked the device)
  7. Tried mobile setup but it fails during the Mesh vs Non Mesh choice (i.e. bluetooth connects)
  8. Left the device flashing green overnight
  9. Tried https://github.com/rickkas7/boron-clouddebug but get a assertion error (white flash SOS 10 red blinks) after boron-clouddebug.bin is flashed.
  10. My last step was to try the above. When I flashed system-part1-0.9.0-boron.bin I got (white flash SOS 10 red blinks)

I re-flashed
particle flash --usb tinker -v

… and tried:

C:\Users\rober\Downloads>particle device doctor
The Device Doctor will put your device back into a healthy state
It will:
  - Upgrade system firmware
  - Flash the default Tinker app
  - Reset the device and server keys
  - Clear the Wi-Fi settings

The Doctor will operate on your Boron connected over USB
You'll be asked to put your device in DFU mode several times to reset different settings.

Flashing the Device Doctor app

This app allows changing more settings on your device

Put the device in DFU mode
Tap RESET/RST while holding MODE/SETUP until the device blinks yellow.
? Select Continue when ready Continue
The Doctor didn't complete sucesfully. Error writing firmware: file does not exist and no known app found.
> Please visit our community forums for help with this error:
https://community.particle.io/

C:\Users\rober\Downloads>

I am now stuck with an assertion error.

Any suggestions?

I seem to have this same issue… My device would never connect (flashing green continuously for hours). I put the device into pairing mode (flashing blue) but my iPhone would not pair with it. I then tried resetting it do the button hold thing until flashing white and it still would not pair. Now since I reset it back to original it now won’t even try to connect. I then followed the steps outlined in this post and got back to my original continuously flashing green mode. I actually have 3 Boron’s to confirm it wasn’t my phone, I attempted to pair with the other two.Out of the 3 I am only able to pair with one of them. I wanted to understand a bit more so I used my computer’s bluetooth “Add device” screen to see if it’s even talking Blue tooth. Oddly enough the two I can not get to pair to my phone says BORON-XXXXX where the one that I can pair to says BORON-2FJRKE. It’s like the Boron lost it’s identity. Another unusual aspect is i can use the CLI to flash my device, list my device but the Particle Identify command doesn’t work.How can I get these devices connected to the cloud again?

Are your Borons blinking blue at the time?

The “normal” reset for such cases would be rapid blue blinking, which you get when you first boot your device and then press/hold MODE for 10+ seconds.
The white flashing would be a factory reset which is only expected to work once you had flashed a factory reset image, which by default is empty (IIRC).

You do have the antenna attached and the SIM activated?
Are all three Borons the same kind (2G/3G vs. LTE)?

(actually 6 Xs :wink: )

This is interesting. Maybe something for @rickkas7 to chime in on.

Yes - I confirmed again tonight it was flashing blue but the device does not respond to Particle Identify.

Yes, the antenna is attached and the SIM is activated. All 3 devices are LTE and use the “build in” particle SIM. I confirmed the SIM is still activated and attached to my account from the particle console. I may have mentioned this already but the other 2 devices sitting 6-12" away on the same table can connect to the cloud. I’ve tried swapping batteries and/or powering right from USB wall charger with no luck.

I did start a support request with Particle and got a response today from Marek @ Particle. One part of his troubleshooting steps included installing the Boron Cloud Debug (https://github.com/rickkas7/boron-clouddebug). During the serial monitor step a noteworthy area of the response was: “…ERROR: No response from NCP”. Whatever that means. I sent this information including screen shots back to Marek. Any other suggestions?

The NCP is the Network CoProcessor (aka ublox module on the cellular devices). For some reasion it’s not responding. This might be indicating a hardware issue.

Thanks for the info ScruffR. Would this also cause the inability to pair it to my phone showing Boron-XXXXXX or would this be something different? My concern is I have another boron that is talking to the cloud without issue but I can not pair it with my phone cause it also shows Boron-XXXXXX.

It wouldn’t explain why the device can’t pair via BLE but in the process of setting the device up via the mobile app it would eventually need to connect to the cloud which it couldn’t without the NCP.