Unable to get Photon out of RED flash error

Hi -

I do realise there is a number a topics on similar issues, I have worked through a lot of them, but have not been able to resolve my issue. Hope someone can help. Please see below:

The photon have been working just fine for about two months running the code in this project.

I have not made any changes to the code I simply switched the photon to a new PCB. These were all pre-assembled by PCBWay so I doubt that there is a problem on the new board. Regardless, and in fear of losing another Photon, I hooked up an old Arduino UNO to match the pin layout and it works like a charm.

The Photon was working, and then it wasn’t. Steps I have tried:

  • I am unable to put the device in SAFE MODE
  • I am unable to put the device in LISTEN MODE

I can however get the device in DFU mode, so I did the following via CLI:

  • Particle Flash
  • Particle Doctor.

Both completed (Doctor returns a timeout error during Wifi setup) but after restarting goes back to the RED flashing error as per the video.

My apologies if I a missing something trivial.

Many thanks
Friedl.

That’s a hard fault - SOS + 1 flash. I2C issue, pointer issue or memory overrun.

I have seen the same on Xenons - 3 in identical boards, 1 works and 2 hard fault. The recovery is complete reload of OS and application.

Can you describe a bit more about your PCB, it might be there is something not quite right - a trace connection across pins? I would suspect the PCB and suggest a very thorough look at it.

1 Like

Hi Will -

Thank you for the prompt response. Please see attached. I indicated with purple cut lines where I found two mistakes on the PCB which was very strange as these signals appear on the Eagle Board file but not on the Schematic file. Regardless, I cut these before placing the Photon on the board.

Also, I doubt they would have had any impact as the merely connected the JST connector directly to the analog pin as apposed to via the 3k3ohm resistor. Also, at this stage, there is nothing connected to the JCT connectors.

The layout is fairly simple as you can see.

  • D7 connected to a NPN transistor to power a relay.
  • D1-3 connected to RGB LED
  • A5 connected to ACS current sensor
  • A2-A3 connected to JST connectors for the purpose of connecting analog sensors art later stage.

The board is powered via the RECOM AC/DC converter supplying steady 5V to the Photon. The High Voltage traces are isolated from the rest of the circuit and only runs through the relay and ACS.

is it possible to fix this error or is the Photon damaged for good? It was working fine for about two months. Also day before while setting it up. Just decided to stop working :slight_smile:

ps: Init is a board problem, why does it not affect the Aruidno Uno? Bit reluctant to place more photons on these boards now, but need to get the product to the client.

Thanks again, appreciate the help!!

Friedl.

Can you take the Photon out of the board and run your code without the PCB?

That is possible if there are design issues that put too much stress on some of the internal components of the controler which don’t immediately cause it to die but shorten its life span considerably.

1 Like

Hi Scruff -

At this stage it is off the board. As per the video, It is completely removed form the board and powered either from laptop or USB power bank. Same error.

Thanks!

Sorry, haven’t looke at the video yet (as @armor already confirmed the SOS+1 panic).
Can you try particle flash --usb tinker -v and see whether the issue persists?


Just tried to look at the video but only get this
image

I have done this as well, let me do this again and confirm whether there are any errors. One sec…

Try this link

Or is there another way to share video file here? I did the particle flash --usb tinker -v but the error persists

I made sure to update Workbench and then ran Particle Doctor again. Everything went well accept when determining the WiFi security step, the following error occurred:

! Something went wrong: Serial timed out while initially listening to device, please ensure device is in listening mode with particle usb start-l
listening

From here Doctor continued preempting the device has been restored successfully, but the error persists.

Thanks for all the help so far.

Just for completeness, have you wiped any stored WiFi credentials off the device (by holding SETUP for 10+ seconds)?

It wiped it during Doctor, also tried via SETUP button. When holding down SETUP button thee following occurs:

  • Couple of RED flashes.
  • Then couple of Magenta flashes (If I release SETUP here, it does not enter Safe Mode, it goes back to RED)
  • After this DFU mode for a while
  • Eventually flashes WHITE for s brief period, then RED again.

Regardless of when I release the SETUP button, it always returns to RED error, excepts if I release duding yellow, then it enters DFU mode.

Hope this helps.

Then it’s probably time to file a support ticket at support.particle.io

1 Like

Thanks @ScruffR

Always sad to see this happen, I don’t like making mistakes especially if I don’t know what the mistake was. I thought I was thorough enough when designing the board :see_no_evil:

Bit reluctant to place another Photon on the board now…

Regards,
Friedl

Observation about your board - the high voltage AC tracks are very close to the Photon. You also have tracks connected to pins on the Photon running over the AC tracks (clearly on the other side of the board). You will get cross-talk and spikes on these lines. This could quickly blow the pins.

Lastly, the 5VDC output from your PSU (AC:DC converter) will need a few capacitors and possibly an inductor to properly smooth the input to the Photon and also if you want to accurately measure the AC current using the AC722.

1 Like

Hi Will -

Thank you, I always appreciate feedback

I was assuming as they are on the bottom layer of a 1.6mm board they would not interfere with the signals on the top layer. I had some prototype boards made and have been testing one for about six months without any problems… ugh.

Would best practise then be to keep these traces from crossing regardless of whether they are on different sides of the board? Sorry if it is a trivial question, still learning :slight_smile:

The RECOM AC/DC converter have some capacitors “build in” if I am understanding the Data sheet correctly and the 5V output seems pretty stable if my Megger Multimeter is anything to go by. I have been getting some good readings from the ACS module, in this case fortunately extremely accurate readings are not necessary, it is only used to give an estimate of the power consumed by the device.

Would you recommend I not try another Photon in this case? Just a question, why is it not affecting the Arduino? I had it on for more than a day switching current on/off every 1s.

Ditching these boards would mean I would have to salvage the parts from the assembled boards and design different ones. These were quite expensive as I had the manufacturer also do the assembly. Space might also be a problem if I want to traces not to cross at all as I already have the enclosures made up, so limited to that particular board size :see_no_evil:

Below is a picture of the UNO hooked up with all the same pins being use with the Photon.

The professional EE design rule of thumb is 3mm spacing with no copper fill on the High Voltage AC side and for ICs like ACS722 they should straddle the 3mm space with an air gap below/hole. Some people even have an air gap / slit between the HV and LV sides or better separate boards.

The output from the RECOM will have flutter since it is a switched power supply even with the built in capacitor - that won’t work well as a reference voltage for the ACS722. You can only see this with a DSO not a multi-meter. It all depends how accurate your measurement of current needs to be!

The Arduino is off board - you could try the same with your Photon using a breadbroad?

1 Like

Hi Will -

Thank you for the comprehensive feedback.

I still find it strange that the initial prototype board did not cause any problems. Time to decide whether this round of PCB’s will be seen as “school fees” or whether I will try one more Photon and hope for the best.

In this case, the accuracy of the ACS is not critical at all… as I mentioned, more just an approximation of the power consumed each day. I will put more effort into studying PCB design rules and practises. I enrolled at ASU so studying full time there as well, free moments are few and far in-between :smile:

Thanks again, I really appreciate the help. In the meantime, I flashed by Photon via CLI with 4 binary files downloaded from Github, but no success.

  1. photon-system-part1@1.5.bin
  2. photon-system-part2@1.5.bin
  3. photon-bootloader@1.5.0+lto.bin
  4. photon-tinker@1.5.0.bin

The best I get is the Photon breathing White. Anything I try form here, it reverts back to flashing red :see_no_evil:

1 Like

Hi @armor -

If you don’t mind, I have a relating question

in an attempt to check for voltage spikes, I connected each of my pins on the PCB (without Photon on the board) across GND to my voltage meter in an attempt to see if I can detect some sort of unwanted voltage reading. As expected, I got 4.95V on the VIN. On the Analog and Digital pins I got nothing to very small fluctuating voltage readings, 0.1V to 0.5V max. Surely this should not damaged the Photon? I also checked for shorts across pins, but did not detect anything.

I am however not sure of this “makeshift test” is something I can rely on to render the board safe to use?

Thank you in advance.

Regards,
Friedl.

For what it is worth - other observations about the schematic:

  1. Can’t see a flyback diode in parallel with the relay coil
  2. Relay coil specified is 12VDC yet you are switching it with 5VDC - assume you subbed a 5VDC version otherwise it would not reach the switching voltage threshold (circa 8V)

If you have any lines going to a Photon pin that run over an AC line that is switched then there is a possibility of a short-lived spike which if there is no small protection resistor (think I = V/R) means a high enough current to burn out the pin buffer. On my very first board I had a connector to a keyboard the cable from that was at one point ‘cable managed’ to be next to an AC cable - that blew the 1 or 2 pins on 10 Photons before being discovered and corrected.

1 Like

HI -

Thanks again for taking time to respond.

On my latest design I included couple of diodes as protection, some arguably unnecessary, but they are cheap enough so rather safe than sorry. I did however not think it would completely destroy the Photon. As I have ten of these boards and they came fully assembled, I do not want to waste US$400 and would like to use them if possible.

I am indeed using 5V coil, my apologies, not sure why the schematic indicates 12V. Was probably having a hard time finding appropriate footprint. I also testing latching relays as apposed to non-latching.

I had some incidents with blowing pins on a previous board design powering TMC stepper drivers (24V 2A). But even in this case, it destroyed the digital pin it was connected to completely, but had no effect on the board aside from the damaged digital pin.

In hind sight… There is the off chance that I removed and/or reinstalled the Photon onto the PCB while it was still powered on. Even though I usually take great care not to have any power on the board while removing components, I cannot for sure exclude this possibility. As I am getting the Photon to flash red, go into DFU mode or breath white, I cannot help but wander whether it is not software/firmware/memory issue that might have occurred in the vent that I did remove/install the Photon whilst there was power on the board. Rookie error… even for me… :roll_eyes:

side note: Have you encountered any issues with Eagle’s Auto router? I was trying to find out why there are “extra traces” on the Board file that are not on the schematic (the ones I cut). I found a couple of articles I the Autodesk forum where people warn against blindly trusting the Auto router, but it has previously served me well. I looked in Altium but the fact that it does not run on OS X and the cost is a bit of a deterrence.

Can’t help you with Eagle Auto Router - I subcontract the board design to the studio at a local electronics contract manufacturer. They also make them (for the first few) and thus if there are issues we get them ironed out before considering contracting to China - really you need to be ordering >1000 to make it worthwhile.

1 Like