Photon Stuck in Red SOS to White blinking Connecting then Disconnecting Cycle

My photon is currently stuck in a red blinking SOS followed by a momentary white. I have followed the guidelines in other posts here for flashing firmware using the Util method as well as the particle CLI methods. Even followed Jon Gallant’s tutorial as well. I am able to send new firmware and even flash the tinker app and get a successful message at the end. However the photon always goes back to the red blinking SOS cycle and I can’t get it to connect to wifi.

Really wish photons had a button sequence to perform a factory reset.

Anyone else able to locally flash firmware, but yet still getting the Red SOS flashing pattern?

Ideas for next steps?

Have you tried updating your system firmware? After updating the CLI with npm update -g particle-cli, try doing a particle update while your Photon is in listening mode.

Moors7 thanks for the response.

I have done the npm update -g particle-cli but nothing happens after I do it even though the command prompt says successful.

Also, I’m not able to put the device into listening mode. As soon as you turn it on it blinks red multiple times, then disconnects, blinks white, then goes back to red. The only mode I’m able to put it in is DFU mode.

I’ve also followed all the tutorials on updating firmware with DFU-UTIL and they also give me a successful message, but yet the device goes back to the red blinking cycle again.

I’ve followed multiple threads attempting to fix it all to no avail.

Hmm, strange indeed. If the Photon entered this state after flashing some firmware, if might have something to do with that. While in DFU mode, could you try particle flash --usb tinker, to see if that helps?

I’ve tried that too and it flashes successfully and then the system, again, returns back to the red blinking, disconnecting/connecting, white flash, red series again.

So you’ve done a particle update followed by particle flash --usb tinker and still encounter an SOS? If you can count the number of red blinks, that might give insight into what’s going on.

That is correct. It is hard to count the blinks, but I think it’s giving 3 quick blinks, 3 slow blinks, followed by 3 more blinks.

Here’s a video of what I’m seeing https://www.youtube.com/watch?v=dNKEjA3Fu1Y

That’s an SOS followed by one blink, hard fault.

Just a random idea; could you try removing the Photon from the board and use a different USB cable and/or power supply?

Tried all of that, still no luck :frowning:

Thanks for the info on the hard fault. Any idea what would cause that to happen?

I have the same issue. My Photon had been working fine for a long time. Then I decided to try a battery pack but I didn’t realize that the two cells were in series instead of in parallel (7.4V instead of 3.4V). As soon as I plugged the battery to VIN and GND the Photon started giving me the red leds (SOS Mode). I quickly removed power from the Photon and then tried to supply power via USB port but I still got SOS Mode.

I followed the steps on this article: http://blog.jongallant.com/2015/08/particle-photon-firmware-flash-windows.html
but I still get SOS Mode. If I try firmware version 0.4.4 I get a white breathing led.

I know that the Photon spec says power should be between 3.6VDC and 5.5VDC and that supplying more than that is stupid, but I think 7.4V shouldn’t have bricked my Photon. This is not a complaint, the point I’m trying to make is that I think the hardware is OK but somehow I can’t get it out of SOS mode.

Any help or suggestions?

Can you enter Safe Mode?

Why and how did you downgrade to 0.4.4? (downgrade sequence is reverse order!)

@pattersonc, have you got your problem solved meamwhile?
Hard fault is usually caused by mem violations of your code.

Hey ScruffR,
thanks for your reply. I cannot enter Safe Mode, I never get the blue led. It goes from blinking magenta when I release the Setup button to SOS Mode (white led, followed by the blinking reds).

I first tried 0.4.7 and since that didn’t solve the issue, I tried 0.4.4 which was the version referenced on the instructions in the article I had [linked][1]

I’m not sure what you mean with “downgrade sequence is reverse order”. To downgrade, I followed the steps on the link above. Obviously, ignore the part where the author tells you to find the latest firmware, and instead download the links he provides for 0.4.4.

On another detail, today I plugged in my Photon to the USB and measured the voltage on 3v3 and GND. I got 3.3V, which tells me that the voltage converter is not damaged.

Please let me know if you think of anything else I can try.

Thanks!
[1]: http://blog.jongallant.com/2015/08/particle-photon-firmware-flash-windows.html

The linked article does tell you how to upgrade from a lower verison to 0.4.4, but if you want to downgrade, you need first flash part2 and after that part1 (hence reverse order).
If you did it the other way round it will definetly not stick.

But since you can’t even get into Safe Mode, you might want to shoot Particle a mail to hello [-at-] particle.io or go to the support page and send them a message there.

I didn’t know that, thanks for the clarification. That could explain why I get a breathing white when I flash 0.4.4.

I will follow your advice and contact particle. I’ll post a resolution or reply when I hear back from them.

Thanks for your help!

1 Like

sorry for the late response here - I was unable to solve the problem and have contacted Particle to discuss next steps

One thing to try is the instructions here - Photon pulses white constantly

If you have a jtag programmer, try erasing sectors 1 through 4 (inclusive) - that’s 0x8004000 to 0x8010000.

I wanted to update my case. I contacted Particle support and, while describing the process that led my photon to SOS Mode, I realized that I had connected my battery pack to 3v3 and GND, not VIN and GND as I had described on my previous posts. Connecting 7.4V to the 3v3 pin is obviously bad and my photon is damaged. I discarded it and bought a new one. Thanks for your help.

2 Likes

Very randomly ran into the same issue, this forum thread seems to be the most complete on describing the issue I’ve experienced today.
I connected my photon to a 5V PSU, it worked fine first - but somehow managed to get into an SOS loop - just like the one explained in this thread.
I contacted particle support, and will update here too. Should anyone have a solution in the meantime - let me know!