[solved] Photon Light is turning Red


I’m new to photon family.

When my photon particle device is turned on the light which are blinking are as follows.
First some Green blinks
and then red blinks and then the photon is getting reset.

I tried putting the photon in safe mode, but in safe mode, magenta light is getting turned on, when I remove hold from setup (mode) button the photon is getting reset and again green and red lights are blinking.

Can anyone help me in this?

Would you please describe the process leading up to this point, and what Particle tools you have installed (if any)?

Hi, @BDub

Thanks for the response, I appreciate it.

I didn’t install any particle tool, but I used the particle web build IDE (https://build.particle.io/build/)
and Particle (android app).

First time using the android app I was able to connect it to the Photon.

Second time when I left the home WI-Fi network and tried connecting it to other Wi-Fi network, I pressed the mode button for 3 seconds and then tried connecting to the Wi-Fi network. Connceting to Wi-Fi process failed at that time and afterword it is displaying the pattern as below

First some Green light blinks
and then red blinks
and then the photon is gets reset.

Hmm, this sounds like an SOS error code. Let’s try to put the latest firmware back on your device. First power your Photon and erase all credentials, press and hold SETUP button for over 10 seconds, or until the LED goes from slow flashing BLUE to rapid flashing BLUE.

Please install the Particle CLI and run the following commands:

With Photon in DFU Mode before each command:

particle update

particle flash --usb tinker

Hi @BDub,

Thanks a ton for the help,

Now it started working fine.

Exxxxcellent! :grin: