Unable to change Mode on photon

I got my photon last week. I connected to it with the particle android app and tried to change the name of the devic (just trying out the options). Afterwards I could not claim the device any more and the photon is stuck with a permanent green led ON. I cannot switch to any other mode. I tried running the photon for more than a minute, no change. Pressing the setup button for way more than 10 seconds no change. When pressing setup, then reset while continuing to hold setup no other LED colour flashes. There is just a very faint red blinking in the lower corner of the led. Once I release the setup button the led goes straight back to solid green.

I already read the post Photon Unresponsive, Solid Green Light but most of the users there could switch to other modes which is why I am asking this in a separate post.

Have you kept SETUP pressed while releasing RESET? (does reset in your quote refer to the RESET button or performing a reset (=short tap RESET)?)
This is the way how it should go into Safe Mode/DFU Mode.

Holding both, keeps the device in reset state, hold/release SETUP while pressing RESET does not make any difference.

Yes I performed a reset and not just keeping the RESET button pressed.

Could it be that your SETUP button is damaged?
You could try that with a jumper wire between GND and the solder pad 26 underneath the Photon

Will have to try that out tomorrow when I go to the uni. Thanks for the quick reply

The SETUP button is working okay. Checked it with a multimeter for short. Works as it should

So when you press hard on the SETUP button before plugging in the USB cable, does it enter safe mode (blinking magenta)?

Sorry I am not quite sure what you mean by

I use the USB cable to power the device. I cannot enter any other mode. While the setup button is pressed the RGB led switches off and when I release the button it goes straight back to solid green.

Did you try as i described?

  • make sure the Photon is not powered
  • press and hold on the SETUP button
  • plug in the USB cable
  • does the Photon blink magenta followed by yellow (do not release the SETUP button)
1 Like

Yes. I tried it. Nothing happens. As soon as I release the SETUP button the led goes back to blinking solid green. I dont if this additional info helps but sometimes when you release the SETUP button you see some other color on the LED but just for an instant. You can hardly make them out.

Can you video the led light sequence?

What happens if you hold the SETUP button continuously… Does it end up blinking blue?

It never ends up blinking blue. Sometimes it might blink blue for a second or less and then goes back to this green state as in the beginning and end of the video. I will try to re-create the conditions under which it blinks to another color for an instant.

Here is the video. Sorry for the bad resolution
UPDATE: Here I got it to blink the other colors but only momentarily.

Tip: Dont know why but to see the video you need to refresh the web page and then the video plays fine.

@Particle_Null, this is weird. Never encountered this before. What was the Photon doing before it entered this state?

Well I connected it to a wifi network and did the initial setup with the particle android app. Then it was showing the name of the photon as photon-hamster and since I do not like hamsters at all I renamed it to something else. After that I could not connect to the photon with the android app anymore so I selected the unclaim device to see if I could connect to the device with the new name. Thats when I realized the photon was locked in this weird state. Any suggestions on what I should do ? Can it be repaired or do I simply return it ?

Can you remember how you named it?
Just to try if we can kill more Photons with that name (might be an “easter egg” :wink: )

Cant remember it clearly. It was photon-something. photon-cadet or photon-commando something. Like I said I was just trying things out so I gave it some silly name. Is it possible to get that information from my particle account ?

Drop the support team a message here to see if a replacement can be done: https://docs.particle.io/support/troubleshooting/common-issues/electron/

Well I bought it through a third party so I do not think filling out this form will be helpful.

Should not it be possible to reprogram the device with a JTAG programmer ?

It is possible if you have a JTAG programmer. Whether you bought the photon from a third party of not, you can still contact :particle: support.

You can request from them the factory binary used to flash on new Photons and the instruction to do so using a JTAG programmer.

1 Like

Thanks I sent them an email