Red SOS blinking while trying to setup


I have searched the solution in the form but unfortunately, I could not find one.
I have been having headache with my new Photon.
It seems to have trouble connecting to WiFi hotspot even though it is just beside the router when I do “particle serial wifi.”
Moreover, I cannot set it up using be it iOS App or CLI.
Whenever my phone is trying to connect to Photon or CLI is trying to connect to set up, it switches to blue to red immediately.
Any help?

Thanks in advance.

Can you place the device in DFU mode and do a particle update first?

Yes. I just updated using particle update.
It was able to connect in version 0.5.3 using CLI (could not connect to cloud when set up with iOS App).
I did the firmware update because it is getting really hot (I can’t even touch the reset button with my bare hand) when it is connected to laptop USB.
After the update, it cannot setup anymore. :flushed:
Now I updated again. Still no luck. :anguished:

That doesn’t sound good…

Are you able to place the device in Listening mode or Safe mode?

You might need to take it out from the anti-static foam as that would possibly cause the pins to connect

Yes. I can put it in Listening Mode ( Blue colour light steadily blinking).
And when I put it to safe mode, the green colour light rapidly blinking.
I used the foam to prevent pins directly touching to my laptop display when I took picture. After that, I removed. :grin:
It just cannot connect to wifi regardless of all these attempts.
I think I messed up the firmware somewhere somehow.
When I sent “v” via serial monitor, it replies

system firmware version : 0.6.0

The latest system firmware is 0.6.1 and Particle-CLI is v1.20.1. I guess the CLI is a little outdated but that’s fine.

Can you place the Photon in Listening mode, press and HOLD the setup button until it flashes blue rapidly? This would clear the wifi credentials.

Next, try particle serial wifi to configure the WiFi credentials and see what happens.

1 Like

I updated particle cli and photon firmware.
And I followed the steps that you suggested.
What is happening now is that It blinks rapidly cyan followed by blinking of red sos light and Photon tries to reboot. And the cycle repeats itself.


Can you place it in DFU mode and do a particle keys doctor PASTE_DEVICE_ID_HERE.
Do change the variable with the actual device id of the photon.

Deducing device DFU version from functional descriptor length
Opening DFU capable USB device…
ID 2b04:d006
Run-time device DFU version 011a
Claiming USB DFU Interface…
Setting Alternate Setting #1
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "DCT Flash "
Downloading to address = 0x00000022, size = 611
Download [=========================] 100% 611 bytes
Download done.
File downloaded successfully
attempting to add a new public key for device [ replaced with xxxxxxxxxxxxx ]
submitting public key succeeded!
Okay! New keys in place, your device should restart.

Yes. Did the steps and this is what the cli said. But it seems to be having no effect.
Cyan rapidly blinking followed by blinking of red light and Photon reboots. :sweat_smile:

Take the conductive sponge off the Photon. (I see Kenneth already commented on that too :blush:)

Just to make sure, after you updated the system do this as well (in DFU Mode)

particle flash --usb tinker

And post a video of your RGB codes after that.

1 Like

I have uploaded the video after flashing tinker on Youtube.
It shows the looping cycle of cyan and red.
It is driving me crazy. :sweat_smile:

That does not look good.
If this happens with Tinker I’m inclined to believe that your “thermal experiment” has damaged the device internally :pensive:

When the temperature issue of Photon accured, it was standalone : disconnected from external circuit. No foam was connected as well. I don’t know where to put the blame on already.:cry::cry:

Opps could you also do a particle keys server in dfu mode?

“particle keys server” couldn’t also help.
I think I found a solution.
I rolled back the Photon firmware from 0.6.1. to 0.5.3 using manual firmware update specified here.
Finally, it can connect to WiFi once again. Hence, previous rise in Photon temperature doesn’t relate to hardware problem. @ScruffR :blush:
I am not sure if this issue is related to firmware 0.6.1 or it is happened to be just me having the issue on one of my new Photons.

So in summary,
0.6.1 = WiFi not okay
0.5.3 = WiFi okay

at least for my particular device. I will never update to 0.6.1 again.

Update : I will do the following suggestions in few days and will definitely post the results here.

@BDub might be interested in this.

If you can help us to verify this by:

  1. Updating with 0.6.1 firmware and see that connection fails
  2. Place the Photon in DFU mode and do a:
    dfu-util -d 2b04:d006 -a 0 -s 0x8000000:0x100000 -U backup.bin
  3. Update again with 0.5.3 firmware and see that connection works
  4. Send @BDub the .bin file
1 Like

It sounds like the issue lies in the user firmware when it’s upgraded to 0.6.1. Please share your firmware so we may figure out why it SOS faults. If the device SOS faults, it will not be able to connect to Wi-Fi or run any user code for that matter.

When your user app is upgraded to 0.6.1, you may not even be getting the system upgraded to 0.6.1 if it reboots and does not go into Safe Mode, but instead SOS faults.

After flashing your 0.6.1 app that SOS faults, try manually updating your system firmware to 0.6.1 with the CLI, and manually entering Safe Mode.

The local method over USB using Particle CLI

Safe Mode

If this connects, it’s most definitely due to your user app faulting. If you share that here we can help troubleshoot.

1 Like

Oh also, please make sure to remove the Photon from that foam. It is conductive ESD foam meant for storage only, not meant for the Photon to be operated in. It really shouldn’t hurt to leave it in, but that kind of depends on what happens as well :slight_smile:

1 Like

@BDub, you’re the third to comment on that (I was second :flushed:)

This is never good.