Strange Error Lights [SOLVED]

I was merrily playing with my Photon, when it seems to have stopped working. I can’t upload any new files to it. The CLI says “Serial timed out”. What does this light series mean, and how can I get rid of it and get onto more Photon phun?!


Hi @krhoyt

Have you tried starting up safe mode yet?

You are getting the SOS followed by one red flash indicating a hard fault, like following a bad pointer etc.

1 Like

Thanks @bko!

That did the trick - I uploaded a new program which runs as expected.

FWIW - the Photon has the “Setup” button, not the “Mode” button of the Core. I made the assumption (bzzt!) that the documentation was for the Core, not the Photon. Should have tried it anyways before posting. Might be worth noting the difference in the docs.

Thanks again,


Just as a side note: the foam the photon comes in is conductive. You might want to take that off when powered on, since it could create random issues.

This has come up a few times. Maybe we should add it to the getting started docs?


@Moors7 @mdma

Yes, I ran across this as well. When I first got my Photon, I just wanted to play with the software without building a circuit. Leaving it in the foam seemed like an obvious way to protect the pins. At some point I noticed that if I picked the Photon up to watch it load new software, I would get mixed results. I put the Photon in a breadboard and new software loaded far more quickly and reliably.