Not able to flash the device!

After several tentative to claim my third photon module, I was not able to flash the code. It says Time out! Also I noticed that the device loses the wifi connectivity several times. The IDE shows the device breathing Cyan, but not able to flash the code. Any suggestion?


If the device is repeatedly losing the connection, can you make sure you’ve got a sustainable signal at the location the Photon is at? Could you try moving it closer to the access point to see if that makes a noticeable difference?

Hi, thanks for the suggestion. I moved them closer to the wifi router and the are keeping the connection fine now. Even the claim was faster. BUT, I still can’t flash the blink led code to any of the 2 devices. I can send the “signal” and the RGB change colours, but not able to flash any code. Error message says:“Request Timed Out”.

Not sure what code your devices are currently running, but try putting them in Safe Mode and then flash again.

1 Like

Tried and didn’t work. The funny thing is that the IDE update the device quickly after unclaimed and claimed, but to flash the code it says time out. Even the Signal button is working.

Ok, I just found out that both devices don’t have a firmware.

System Firmware: unknown

I tried to put in Safe Mode and flash, but still not flashing. Any suggestion?


Ok. Finally I was able to update the firmware through CLI. Thanks for the suggestions.
Thanks again.