Photon breathing cyan but shows offline in CLI, flash timeout

I ma rather new to the Photon, but all was working well and then I had a timeout on flashing code. I did hard reset, wiped, memory, etc. I can reset the WiFi credentials just fine and it is breathing cyan, but shows up offline in CLI (particle list) and times out when I try to flash. How do I fix

Can you place the photon in safe mode?

I did but it was still offline. Not sure if I should do something special after placing it it safe mode.

Can you go to https://console.particle.io/logs and hit the reset button on your Photon? Do you see any events published when the device is breathing cyan?

Thanks for helping. nothing in the log.

I now seem to be having trouble putting it in safe mode. I do mode-reset, let go of reset, let go of mode when flashing magenta. Then it shifts to flashing blue. If I then reload wifi credentials it returns to breathing cyan but showing offline in the CLI: particle list command

now in safe mode but still offline. What should I try next? Thanks

If it’s breathing magenta, don’t pay too much attention to the online/offline indicator.

But you may want to upgrade your firmware to v0.6.0 via the most recent CLI and in DFU Mode with

particle update

I was able to successfully update the firmware to v0.6.0, re-established wifi connection but still cannot flash code either in normal mode or safe mode. What next?

In case it helps - I was able to compile the trivial LEDBLINK app and flash it over the serial connection, but not over Wifi. While the flash was successful, it did not automatically run

Can you describe the steps for building and flashing as exact as possible and give us the exact commands you are using with the respective outputs?
Also give us the exact code you use for your tests.
And if possible also post a video of the color codes you see while attempting an OTA flash.

As the thread indicates, things were working fine, then I received a timeout flashing an ap. Since then I have updated the the firmware using the particle update command. I have tried the mem clear and wifi clear as well. As indicated, my attempt at a factory reset never gave white flashing

I have built the LEDFlash code either in the desktop or Web app and have tried to flash using those apps - all with Timeout. I also compiled it using the particle compile command - it would not flash using the particle flash (again timed out), but I was able to flash using the --serial option (with lights flashing blue). While this flash reports success, the LEDs never flash.

As for the lights I have tried OTA flash from the normal breathing cyan mode or when put in safe mode (breathing magenta). In neither case do the lights change one bit.

I have no trouble changing the Wifi credentials, it always accepts and resets just fine. Otherwise it acts as if the WiFi isn’t working to receive the flash. Although it was suggested I ignore it, particle list shows it offline

There is no factory reset on the Photon.

This “success” report is not to be trusted, you can throw any .binfile (even a pure text file) at the device with that command and you will always get a success.
Rather try particle flash --usb firmware.bin in DFU Mode (blinking yellow).

That indicates you are not targetting the correct devices.
In Particle Build you will find a SIGNAL button under your device details to check wheter or not you are actually targetting the correct device.
If you are, your device should show a rainbow pattern on the RGB LED.

And there is a very specific reason why I asked for this

Without that I won’t be able to help any further (and others will have difficulties too).

1 Like

Many, thanks. I was not communicating with the correct device. Also, my apologies for not appreciating the differences between the different Particle devices and for inappropriate etiquette. Lessons learned.
Best - David

1 Like

I’m having the same problem with a photon that I ordered a while back. The device is connected to wifi, I can see it in build, breathes cyan, I can ping it, I can signal it and see the led rotate through the colours.

I’ve tried putting it into safe mode but the video doesn’t seem to indicate what colour the led should be breathing when it’s in safe mode (is it supposed to stay breathing magenta?), so I suspect that I might not actually have succeeded in doing so. I hold down setup, press reset, wait for the flashing magenta and then release the setup button. It always comes back to breathing cyan.

Any help would be appreciated.

Cheers,
Dave


Moderator: Please reply to this post in the dedicated thread

1 Like

@dwthomas72

I am having the same exact situation!

Please see following post for solution.

Hi @dwthomas72,

I found the following post by @ScruffR works! It brings these old relics back to life!

Someone, please mark this as solution to this problem.

Thanks,

Joey Morrow

1 Like