Cannot flash photon with new code

Since yesterday evening, I have not been able to upload any new code to my photon. I’ll try to provide as much detail as I can:

  1. Did factory reset several times. Tinker never seems to load. After I reset it breaths cyan.
  2. I just realized after connecting it my serial port that some old code still seems to be running on the Photon. The factory reset didn’t seem to wipe it.
  3. I put the photon into setup mode (blinking blue) by holding down the setup button for three seconds. When I type “s” I get the following output:


  1. Whenever I try to flash with the Web IDE or the iOS app, I get the 500 time-out error

I’m not sure where to go next. I have been primarily using Particle Dev to write my code. Any help would be appreciated on the next steps to take.

Place the device in Safe mode (hold BOTH buttons, release RST and once blinking magenta, release SETUP)

It should now connect to the :cloud:

Try flashing a blinky now. :wink:

Well that seems to have fixed it! Thank you much. Tinker is now up and running. I’m going to get back into Particle Dev to see if I can upload from there as well.


Good to hear you’re up an running again :+1:

Just to point it out, exactly situations like yours were the reason why this topic is pinned :wink:

1 Like

Hi ScruffR,

I am running into similar issues.
After a rest, my photon now breathes cyan and the particle dashboard shows I am online and the logs keep getting updated every 30 seconds that the device is online.

The problem is I am not able to flash any code. I also tried going in safe mode and retried but it says Flash unsuccessful.
When I login to the particle app in iOS it shows the device as offline. Please help.

How do you try getting into Safe Mode?
What does your currently on the device running code look like?
Have you considered flashing via USB?

For safe mode, I pressed both reset and setup then continued pressing setup only until the magenta lights came on. When viewed in the dashboard, I get “Device came online” every 26 seconds. The behavious is same if I power on normally. cyan light breathing as if everything is normal.

When I try to flash from Web IDE, it takes a while then “Flash unsuccessful”

In Cli, I tried to show “particle list” and it shows the device is offline.
I tried flashing to 0.4.9 and that went through but after the restart I have the same problem.
I then tried to flash tinder, and the flash fails.

Can you tell me how I can view what code is currently running in the photon?

There is no way to actually view the code running, I just thought you might still have the project source which you used for the last successful flash, when the problems began.

You mean flashing Tinker via CLI in DFU Mode failed too?
Have you tried it this way?

// put device into DFU mode (flashing yellow)
particle flash --usb tinker

And just to be on the save side put the device into DFU Mode again and do

particle update
particle flash --usb tinker