How to get started?


I have two Photon, I have found an easy example i want to test, but led will not blink:

//D7 LED Flash Example
int LED = D7;

void setup() {
pinMode(LED, OUTPUT);

void loop() {
digitalWrite(LED, HIGH);
digitalWrite(LED, LOW);

I have tried many things now but cannot get it to work…
I know it’s connected since the RGB led turns magana when i press Flash in the web tool.

Is there something else i need to do ? start the program on the photon or something like that?

Thank you…

  • Did the standard tinker firmware work when you first setup the Photon?
  • What happens after the LED turns magenta? Does it reconnect to wifi (flashing green, then goes to breathing cyan)?

I think it worked, i was able to connect to my wifi without any problems on both. Could it be the firmware that needs update?
And yes it breathing cyan after flashing green.

What does the particle Android app say? Does it say Online, not Tinker (yellow light) or does it say Online (green light). If it’s Green, click on it , which will take you to the tinker app, where you can click on the D7 and digitalWrite High and Low to it. This also means that the firmware didn’t flash successfully. It never hurts to also apply the latest firmware, found here

In the android app is the Device Green (Online) and i can turn D7 on / off manually.
I will try update the firmware. Thank you.

I have made the firmware update, but now the Phonton blinking green all the time…

try clearing wifi credentials:described here.

@ramgaard ,

  1. You are using the web IDE ( ?
  2. Does “Verify” say your code is verified?
  3. Can you see your two photons in “Devices”, with two different namas?
  4. When you hit “Flash”, does the web IDE report success, or failure?
  5. Are the two Photons received recently, or several months back?

@mumblepins - I have updated the firmware and re connected to my WiFi
@Jack -

  1. You are using the web IDE ( ? - Yes
  2. Does “Verify” say your code is verified? - Yes
  3. Can you see your two photons in “Devices”, with two different namas? - Yes
  4. When you hit “Flash”, does the web IDE report success, or failure? - Success
  5. Are the two Photons received recently, or several months back? - Recently. last week.

Thanks for the help so far.

CHIP-1 says: Online
CHIP-2 says: Online, non-Tinker - and my program work on this.

The problem now is when i disconnect the power, and power it up again are they blinking green… and does not get on my wifi again… I have tried change my WiFi channel from 2 to 7. But same. I can connect them to the WiFi again if i reset the wifi pressing RESET for 10 sec.

1 Like

I don’t understand why this is happening. But one off the wall thought. Maybe the pair are confusing each other. Have you tried turning one off, and just working with the other one?

Have you been using the pair really close to each other (a couple inches) ?

Anyone with thoughts, jump right in here. Is it normal for “Flash” to report “Success”, and actually be unsuccessful?

@Jack, the way the flash command works, yes, it is possible to have a success report on the flash, without actual success. All the process reports at this time (I believe) is whether or not the device has received the flash image, not whether or not the flash was successful.

As to the problems, they are a bit puzzling. They sound like the Photon is having trouble finding the Wifi network. FYI, I wouldn’t use 2 or 7, as the only non-overlapping channels are 1,6, and 11 on the 2.4 Ghz band. I’ve had difficulty with both the Photon and the Core in very busy wireless environments, with them taking up to a minute to connect to Wifi.

1 Like

I have the same issue when flashing the latest 0.4.2 branch. only way to get it to remember the credentials again is to flash the system_pad_BM-09.bin from the 0.4.1 release. you will see when you flash it, it will probably magically connect without even entering the wifi details :slight_smile:

Ive been trying for 3 or 4 days to get 0.4.2 flashed to my photon and have it remember the wifi details. Ive since given up and use it in semi-auto mode and not connected to wifi.

Hopefully after the weekend there will be a few more people around to help us.

1 Like

Thank you !
It works perfectly !

@ramgaard, It is working now, Great !
Do you know (have an idea) what was the problem, and what fixed it?

Re: your comments, @Hootie81, I’ve been lucky, the following works fine for me for 0.4.2:
-get a new photon
-get it on my network with the Android Particle app
-let it do it’s auto-upgrading thing (flashing magenta for awhile)
-name it on the web ide
Then Local compile on 0.4.2
-make PLATFORM=photon clean all program-dfu v=1 (from modules folder)
-make PLATFORM=photon clean all APP=my_app_name program-dfu v=1 (from main folder)
and all is well. Just luck because my knowledge is fairly limited.
The hardest part for me definitely was setting up the local toolchain

I installed firmware 0.4.1, I have tried one more time with version 0.4.2, but still same problem. So I will use 0.4.1 until there is a newer version, or a fix that works :smile:

Thanks a lot.

1 Like