Online, non-tinker problem

hello everyone,
I bought a photon particle to connected my hardware to the internet, I downloaded the app on my android phone and followed the instruction, the device is online and I can turn on and off the LED on the photon then I downloaded the blynk app and followed the instruction to display some variables on the phone using the blynk app, while flashing the code , the system asked to choose a firmware 0.5.3 and above and it said that the device firmware is 0.4.3 I select the firmware 0.6.1 and flashed the code successfully, after that the photon turn the red and blue light on and the blynk app didn’t work I get back the particle app and it said device online, non-tinker, I tried the re-flash tinker from the phone it didn’t work, I tried the flash a tinker code from the web it didn’t work,
help me please.

1 Like

Was the LED red or magenta? Flashing an update for the firmware version takes awhile and can stay in the magenta (purplish) state for awhile while updating, I’ve also found that the D7 LED is dimly lit during this process.

1 Like

When you flash a new app that targets a higher system version than the one on your device, you will see several phases of magenta (= red+blue) flashing with subsequent resets.
This is perfectly normal as your device needs to update the individual system modules first, before being able to flash your actual application firmware.
During this update process you are not allowed to reset the device manually. You just need to allow for it to happen till the device stops blinking magenta and resetting.

And it is also absolutely normal to get the non-tinket message, since your application firmware has replaced the original Tinker firmware.

In order to reflash tinker, you may want to enter Safe Mode and then try the app to reflash Tinker.
Another way to deal with this is by use of the Particle “power tool” CLI.

What OS are you using on your computer?

1 Like

Do you have any idea how much time it will take to update the firmware ?

My last update was from 5.3 to 6.1, it took a couple of minutes.

1 Like

Usually you’d see three to four magenta/reset cycles (each about 10~30sec) before returning to normal operation.

2 Likes

now the LED turn blue without blinking and on my phone it says that the device is offline, i’m afraid if I rest the device it will start all over again

You can try to enter your WiFi credentials again using this
https://setup.particle.io
Just select the Photon Beta setup and follow the instructions.

1 Like

I connect my laptop wifi to the photon but the page stayed in step 1 and says waiting for you to connect to your photon !??

What OS are you on and what browser are you using?

With Chrome on Windows 8.1 it works for me each time.

But if that also doesn’t work for you, you may have to go for CLI.

I’m using windows 10 with chrome