Photon keeps breathing magenta, only loads Tinker. [SOLVED]

I have three Photons all with the same problem. Using the Web Dev I can flash Tinker and the Photons will come up breathing cyan. If I try to flash Blink LED from the Web Dev I get a lot of flashing magenta, LED off time, system resets, more flashing magenta, etc. Eventually the system settles down to breathing Magenta.

So, I can load Tinker via Web Dev, but I cannot load any other application firmware.

I have tried to flash Blink LED several times, each time waiting about 30 minutes. I have also done it for hours. I left it overnight last night. I am still faced with three photons that can only run Tinker. I submitted a support Ticket about this.

If I put the Photons in softAP mode I get “0.4.4” back from the “v” command.

This is driving me nuts. Any ideas?

If someone could acknowledge that there is some problem here that the the Particle team is working on, then I will go quiet for now and wait to hear of a resolution.


Thanks for reporting this, and I’m sorry for the frustrating experience you’ve had so far.

We are hearing of a small number of cases where things aren’t working the way we want them to, so we believe there is a problem that is affecting just a small number of devices.

Please send a PM to me and @Dave with the IDs of the devices that you’d like us to investigate.

As an interim solution, you could use particle cli to directly flash the system firmware to one of your devices so you have something working, if you wouldn’t mind leaving the other two as they are so we can help troubleshoot what isn’t working.

use particle-cli like this:

  • put the photon in DFU mode (flashing yellow)
  • run npm -g install particle-cli && particle update. This will update the particle CLI to the latest version, and then update the firmware on the connected photon.

One thing that comes to mind when flashing blinky from the Web IDE - be sure to make a change to the app so that it is recompiled. This is necessary for the system to receive the latest firmware.

Thanks for your patience, please bear with us and we’ll get you up and running again!


1 Like

Just a quick note, I had a similar experience here.

I updated Particle Dev. Then made some changes and flashed via Particle Dev. I was expecting the magenta flashing to take awhile thinking that the app and the firmware were going to be updated. The magenta flashed for the usual amount of time, however when the Photon reset it went into a breathing magenta state.

I could flash tinker on it with my iPhone, however it wouldn’t build anything with Particle Dev.

I went to the web builder and selected the blinky LED program and flashed that. It flashed magenta for quite awhile, I’m assuming this was the firmware update. Weird though, it seems to run my old app after it finished. I pressed reset and then it ran the blinky LED program.

Everything seems to be working fine with the Photon, just a little bit of temporary weirdness with the firmware update.


Thanks for letting me know it isn’t just me.

The npm gave some error on my Mac, so I’m going to try the web ide idea first. I forked Blink ad added int i=0; to setup(). Unfortunately the web ide won’t compile - it gives a fleeting error about server did not process the request in time; I guess your web side is down right now. I’ll try it again in an hour.

I’ve now tried to flash a modified Blink LED via the web IDE, that didn’t change the behavior.

I then tried to use the particle CLI to flash the 0.4.4 firmware parts 1 and 2. It seemed to work, but didn’t change the behavior.

In both cases it still breathes magenta after the updates.

I will message Doug and Mdma as suggested. Thanks for the help.

Ok. A little miracle. One of my Photons now seems to work. I flashed Blink LED via the web IDE again and it picked it up. I don’t know why. I’ve sent a private note with the ids of the two that are still magenta only.


All my five photons are now working correctly. Here’s what I did…

Put the Photon into blinking Yellow mode.
From the command line: particle update
From the web IDE flashed Blink LED
Ta-da, working.


I’ve been having a similar experience – Cores won’t accept new code from the web IDE. Finally, like @JSchrempp, I used the CLI to particle update and then pushed my code directly from the CLI. From that point on, it accepts code from the Web IDE. Seems like it just needed a kickstart… Worked on two different Cores. Haven’t had the issue on a Photon yet.

1 Like

If this is happening on a Core then that’s an entirely separate issue, since the core does not have separate system firmware. It’s likely that your original firmware was blocking the OTA update, and that flashing tinker from the command line provided good firmware which allowed the OTA update.


Not to pile on, but I’ve got the same issue. Cannot load the Tinker app through the iPhone app though, but

particle flash --usb tinker

is working. Get’s me the tinker app back. But as soon as I try to flash something using web or Particle dev, it breaths magenta again.

Took all the steps above, but none where helping. Any ideas?

Update: On a hunch I changed the firmware version of the Photon back to 0.4.3 (guessing the Tinker app has been build with that version?). This did the trick, as I am now able to use the Web Interface again. Particle Dev does not work.


1 Like