Regarding Tinker flash process

Dear Particle Teammate,

I configured my photon device and connected it to the wifi network.But when I tried to “reflash tinker” using tinker app I found that my mobile app showing me “Magenta breathing” and If I tried to enter the tinker it’s showing as —“Device is being flashed.Please wait for the flashing process to end first”.
My doubt is
1)How long does it take to complete flashing process?
2)I am not finding tinker button in my mobile app in this condition as it is in flashing process, so how can I get Tinker app back.
3)But if I flash an example through Web IDE I am able to see the changes on board, how come this.I don’t understand where is the problem actually.

If it is in flashing process how can the device accept the Code uploaded from Web IDE.A lot of confusions…

Breathing magenta means it’s in Safe Mode, blinking Magenta means it’s being flashed. Flashing Tinker might activate the Safe Mode healer if your device wasn’t up-to-date yet, as far as system firmware goes.
Let it update for a bit (blinking/breathing Magenta), and then try flashing it again. That should resolve most issues.

1 Like

Hi. I have similar problem. I am using a Sparkfun Photon RedBoard. I have a breathing cyan LED on the Photon. But my Photon on my Tinker app is breathing pink and provides the same message: "Device is being flashed.Please wait for the flashing process to end first”. I have waited overnight for the flashing process to end. It is still being flashed and breathing magenta.
Why do I get conflicting outputs - blue on the RedBoard and on the IDE WEB and pink on the Tinker app?

In that case a reset won’t hurt the device.
See what happens after that.

If you have CLI installed (which is a handy tool in any case), then you could try

particle update
particle flash --usb tinker