Photon does not work; Alternates breathing/blinking magenta

I have a Photon, it doesn’t work.

Been through setup, it connects to WiFi ok. Can’t get it to run any programmes, it just breathes magenta and occasionally flashes magenta.

I’ve tried:

  • Updating firmware in DFU mode.
  • Performing factory reset.
  • Letting it do the magenta thing for hours.
  • Resetting.
  • Reflashing the blink and tinker examples, console says it flashed successfully (It didn’t).

What else is there to try?

Breathing magenta means, connected to the :cloud: but not running any user code.

Blinking magenta means the Photon is currently getting an OTA system firmware update since it is new so do be patient and let it do it’s magic (5-10 minutes) until you see a breathing cyan again. :smile:

Or the fastest way is to grab CLI and do a particle update via DFU mode

Hi kennethlimcp,

I mentioned above that I have left it to update and updated via DFU. Neither make a difference.

Ok so it is updated via particle update i guess? What is the status of the RGB led when you power on? Try placing it in safe mode and flash some app like blinky

How do you place it in safe mode? The docs do not explain this clearly.

I did a search and got


So what will the LED do when the device is successfully in safe mode?

In safe mode, the LED breathes magenta (pulses at about 12 beats / min)

If you have the Particle CLI, you could try running the particle update command. This should update your Photon’s system firmware to the latest release. Hopefully this helps!

— Nexxy

I have the same problem. Havel already updated the firmware using CLI.

I have a small program (that was running till yesterday) that I have tired to install on two different Photons using the CLI, Particle Dev and Web! Same result:

Both Photons seem to get the program - towards the end of the flashing process flash green briefly and then instead of cyan breathing, both start breathing magenta!!

I have been using one of them for several weeks now without any issues with same and other programs. Have also isolated it from all other hardware - just in case.

The 2nd Photon was setup as a new device today.

Am completely stumped!!

Breathing magenta indicates safe mode - that the system firmware needs updating. Please see the instructions here:

I had the same problems with 2 of 4 photons. i solved it with “particle update” via DFU. but it only worked AFTER i did npm update -g particle-cli in the node.js console before.

Right! :wink: As it says in the post I linked above, you have to update the Cli to get the latest system firmware, or your just flashing the old firmware. Automatic download of system firmware to the Cli is a planned feature but not there yet.

Both my Photons work now! Had to do the Particle update using:

npm update -g particle-cli && particle update

The weird thing was that the working Photons just stopped working suddenly!! And the new one did not work either. But both OK after update.