New Problem with my 4th photon

Dear group,

I have followed the instructions for getting with photon. After I passed the wifi credentials using the application , the photon got in a mode where the magenta led breaths . And it says in the application that my claimed device is not online.

I push the reset button , it tries to connect , and fails and goes in the breathing magenta .

Any solutions?

Thank you again

Is it really breathing, or is it blinking? How long have you waited before pressing reset? New photons will get a firmware update when they first connect, which can take a while.
If you’ve got the CLI installed, hook it up in DFU mode and issue a particle update to expedite the process. Otherwise, give it a bit of time (max 10 minutes) and it should sort itself out.


What a coinsidence, there is another thread with a similar question
Help with setting up Photon (stuck in safe-mode)

And some other post of yours that might be related too
About flashing again the firmware


my photon was behaving similarly to yours, after doing the update as suggested by @Moors7 worked fine and has since been working fine.

1 Like


Is the firmware 2 parts?


I have tried the following but still the photon after that breaths magenta, even when I push the reset button it starts 1) white 2) flashing white 3)flashing yellow 4) breaths magenta

ioannis@ioannis-Inspiron-5547:~$ particle flash 2f0039000c47343432313031 system-part2-0.4.5-photon.bin
attempting to flash firmware to your device 2f0039000c47343432313031
ioannis@ioannis-Inspiron-5547:~$ particle flash 2f0039000c47343432313031 system-part1-0.4.5-photon.bin
attempting to flash firmware to your device 2f0039000c47343432313031


As far as i know it has to do part 1 before part 2. i just used the particle update command. nothing else.

1 Like

Just typed particle update flashed magenta for about 10 minutes, pressed reset, flashed magenta for another 5 minutes, then reset itself, had to move it to within 20 feet of the router then it connected, after that it connects from other end of the house with no problems.

OK I will try it right now and tell you if that works.

NO nothing happens ,

I tried first the part1 , and then the part2 . And when finished still is breathing magenta

I do not know how to update it. Is there a special comand?

Please stick with only one thread that deals with this problem!

I’ll close this and discussion should continue over there
About flashing again the firmware

1 Like