Help with setting up Photon (stuck in safe-mode)

So, I just bought a couple of Photons, I was able to set up one of them. However for the other one, I can’t make it work. I have tried setting it up multiple times and the setup goes fine. But then when I start it up, it “breathes magenta” , which after some digging I realized is safe mode. However I am unable to see it online anywhere. Based on what I gathered from the users here I could update the firmware to make it work. I am putting it in DFU mode with the Yellow light flashing, and the windows device manager (I am using windows 10) shows “Photon DFU Mode”. But when I run dfu-util I don’t see the device. When I run “particle update” it says cannot find any device in DFU mode. Is there something wrong with the unit I received or is it something that I can fix? Any help would be greatly appreciated.

Have you installed the DFU drivers?

Tutorial: Installing DFU-Driver on Windows [24 Feb 2015]

and while you’re at it you can also install the USB Serial drivers

Just be aware, in Win10 you’ll find the Photon not under “Other Devices” but under “Ports COM/LPT” and your Photon needs to be out of DFU Mode - best in Listening Mode (blinking blue)

Thanks for the quick response. I have installed the USB (photon) drivers and can see the device in serial using particle-cli. I have installed the DFU drivers as well. I had installed the libusbK driver as shown in the link you gave. But dfu-util was not showing any devices. And “particle update” was showing no DFU devices… However the device was blinking yellow and the Windows Device manager was showing “Photon DFU Mode”. Then I found another link where someone said to use the WinUSB driver, did that, but still nothing.

Do you mean even for firmware update the Photon needs to be out of the DFU mode in Windows 10? I set the Photon in Listening mode and tried running “particle update” but still it complained that no DFU devices. I can access the device using particle-cli and ave tried setting the wifi multiple times, but its also not connecting to the internet/cloud.

If you want to flash via particle flash --usb then the device needs to be in DFU Mode.
If you want to flash OTA via particle flash [deviceName] it needs to be out of DFU.

I’ll check what my Win10 says about a connected DFU Photon and what the driver properties report.

Under what section do you find your Photon in DevMgr?
Mine gets displayed under “libusbK USB Devices” and the properties say "driver libusbK, 01.12.2014 Version"
How does yours look?

BTW: Is your Photon actually breathing magenta (which would suggest WiFi connectivity) - if it is breathing, could you try flashing OTA? This might trigger an automatic firmware update (which can take 10 minutes or so). This could solve something too.
But don’t interrupt the flashing. The Photon will blink magenta and restart and go back to magenta three times before it’s done.

1 Like

When in the Listening Mode or the breathing magenta (Safe Mode)I find it under “Ports (COM & LPT)” as Photon. When in the DFU Mode (blinking yellow) I find it under “Universal Serial Bus devices” as Photon DFU Mode (this is with the WinUSB driver). When using the libusbK driver it shows up under “libusbK USB Devices” as Photon DFU Mode.

Yes, the photon is breathing magenta. When I power it up, it starts with steady white, then blinks green, then blinks cyan then starts breathing magenta. But I am unable to see it online anywhere. So I am unable to flash OTA.

Thanks for looking into it.

I guess you don’t see it because it wasn’t claimd to your account yet.

Just put your Photon into Listening Mode, then run particle serial identify.
Then you get your device ID.
Then run particle device add [device ID]

After that the device should show up under your account.

For DFU, I’ve had the best results with libusbK and so do a lot of other Elites who use Windows. hence I’d suggest you go for that.
And after installing this have a look in the driver properties again, to see if there are any problems reported (and post the version).
Then do the ominous Windows restart (just to make sure ;-)).
And try particle update again.

Do you get DFU access on your other Photon?
Try particle update on the working one and see how it behaves - don’t interrupt the update otherwise you might get stuck with thisone too :sunglasses:

1 Like

I am pretty sure something is up with my photon… heres what i did.

Thanks for suggesting to hook up the other photon on DFU mode. Turns out the Windows DFU drivers were no good. Eventually set up a Mac OSX machine and then could access the DFU mode on both the photons.
Now, with the problem Photon i flashed the firmware using “Particle update”. it said its successful, but on restarting it went back to the breathing magenta mode. Flashed again, same thing. Weirdly during the power up phase after the second flashing, it blinked red thrice. In any case, after that put the photon in Listening mode and first removed it from my account (since it was already claimed under me). Then reclaimed it and proceeded to setup`the wifi. From the cli it reported that everything went fine. It said, the photon has made it to the cloud, and asked me to give a name for it. (Same as before). But i don’t see it online anywhere. And upon powering up, its back to the breathing magenta.

That’s rather odd and I’m at the end of my wits.

I think it’s time to call on the big guys @mdma (for firmware) & @Dave (for claiming issue).

But be patient - it’s weekend and these guys are knee-deep in the works :wink:

1 Like

Blinking red 3 times just indicates a connection issue - it’s usually temporary and resolves itself.

Before you did particle update, did you also run npm install -g particle-cli to update your cli?

After performing the system update, it’s a good idea to flash tinker

particle flash --usb tinker

Thanks a lot @mdma. Flashing with tinker did the trick. Now i have two working photons. Yayy :slight_smile:


Also did the trick for me. Thanks for the @mdma

This got me back to a connected photon… but when i try to flash my .ino from the particle-dev IDE, the code goes back to booting to safe-mode. Any reason that might be. This code was previously working fine.

Could it be some compilation issue in the cloud?

We’ve just pushed a release, and particle dev does not update system firmware. Particle Firmware Updates Thread

Please see that article for advice on upgrading.

Hey guys, so I’ve done the following:

particle update
particle flash --usb tinker
particle serial flash tinker

Flashing stuff from build straight up fails with “Request Timed Out”. Local flashes however do work but land me with a magenta instead of light blue light

And I still end up with a breathing magenta light. Any help would be appreciated.


What version CLI are you running?


Also I left them running overnight in hopes that they will auto update but they’re still breathing magenta

If they haven’t yet, I don’t think they will.

What was the system version on the device before you tried the update?
Was the device part of a product?

You may want to try this

// in DFU Mode
particle flash --usb tinker
particle update
particle flash --usb tinker

Download the the bootloader binary from here
and then in Listening Mode

particle flash --serial bootloader-0.7.0-photon.bin

I haven’t used them in a very long time so I don’t know what the system version was before I tried to update.

I’m not quite sure but one probably came from an internet button and another from this kit that has a water and carbon monoxide sensor.

I will try what you posted and get back to you.

Flashing the bootloader worked! Thank you so much!

1 Like