Photon is breathing cyan but always shows offline in Particle mobile

The CLI doesn’t see it at all and the Particle Dev app sees it as online. also sees it as online and will successfully signal. However, flashing code always ends with “Flash unsuccessful.” with a “Request Timed Out” error. I’m just flashing unaltered “WEB-CONNECTED LED” code and will do the same with empty setup/loop code.
Any suggestions?

Does it do the same thing in Safe Mode?

1 Like

I can’t seem to get it into safe mode. I’ve followed the instructions and even watched a youtube video to confirm I was doing it right.
I hold down both RESET and SETUP, release RESET and continue to hold down SETUP. It immediately fast-blinks magenta so I release SETUP.
It goes white for a spit second and then just blinks blue. It never goes anywhere from there. If I use Particle mobile at that point to connect it, it ends with breathing cyan – and OFFLINE on the Your Devices screen.
I just did it again but did the sequence much faster. Instead of blinking blue, it went to blinking green, and in a few moments was breathing cyan.

Can you post a video of that?



Can you put the device into DFU Mode and do this?

particle --version
particle update
particle flash --usb tinker

The CLI version should be 1.21.0 (or higher).

Got it into DFU Mode (blinking yellow):

C:\Users\LRG>particle --version

C:\Users\LRG>particle update
!!! I was unable to detect any devices in DFU mode…

Your device will blink yellow when in DFU mode.
If your device is not blinking yellow, please:

  1. Press and hold both the RESET/RST and MODE/SETUP buttons simultaneously.
  2. Release only the RESET/RST button while continuing to hold the MODE/SETUP button.
  3. Release the MODE/SETUP button once the device begins to blink yellow.

It’s still blinking yellow.

You are using Windows. Then you’ll need to install DFU drivers.
If you installed CLI with the installer, you might have forgotten to tick the driver checkbox.
If you used npm to instally, you can use zadig to install the drivers

Also check Device Manager whether you see the device there, try another cable, another USB port (not 3.0 if possible)


Success. It appears the drivers simply failed to install when I installed CLI the first time. After re-installing, they installed successfully and the computer saw the Photon in DFU mode.
So, after the “particle update” (which failed the first time, but worked on a second attempt) the Photon will go into Safe Mode now. It wasn’t exactly necessary since the both CLI and the Photon Mobile app now see the device. I ran the “particle flash --usb tinker” command and then Tinker became available.
I also tested and it is now interacting with the Photon as expected.
I’m still seeing the following error, but I assume this is expected:
“Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!”

Thank you very much ScruffR for taking the time and effort to get me straightened out. I’m very much looking forward to experimenting with the Particle Photon!


Yup, this is just a warning that doesn’t really indicate a real problem and is fine to ignore.

1 Like

Thanks for the help @ScruffR! Glad you were able to get it fixed @Slarti!