Photon Red blinking and white breathing

See this:

After working with it sometimes with a servo, I tried to flash code and it stuck in this mode.
I tried going into safe mode but it prevented me (it got back to this red blinking).
I then tried to flash basic code (blink) via build and it failed to send.
The photon can’t get online anymore.

Also, doing something like

particle flash --usb thinker

while in DFU mode (blinking yellow) does this:

You should try Safe Mode again. Maybe you can even provide a video of you trying it.
The white breathing suggests your app code is either using MANUAL mode or and the SOS code suggests some buffer overflow or such, so Safe Mode should help both issues.

About DFU, have you got the device plugged into your computer (sorry for the question), tried a different USB cable/port and if using Windows installed the drivers using Zadig?

1 Like

Here are two videos.

The first one is the one showing me going into DFU mode, but the computer not recognizing any devices in DFU mode. It seems that everytime it breathes white, there’s a sound from my computer alerting that an unknown usb device is not recognized. The video also shows all the devices inside the “Device Manager”.

The second one is me trying to go into safe mode, but it doesn’t (it should normally blink purple in that state). I also show that the device is connected correctly via a usb cable.

I’ve followed this tutorial, but my device wasn’t listed as DFU as it should, Zadig didn’t work:
could not allocate ressource.

OK, the inability to enter Safe Mode is odd and in order to do anything about it you’d need to get DFU going.

Can you try to re-download zadig (or from here) and run it again (maybe as admin and first without a Photon attached)? (BTW I and other long term members prefer the libusbK drivers over WinUSB with the Particles)
If you see the same error again, could you post a screenshot of the msg and maybe the eventlog too?
Has your laptop got a different USB port to try (possibly USB 2.0 rather than 2.0)?
Sometimes the Photon can be picky with USB cables, try some others and also remove the Photon from the breadboard.
Or can you try another PC?

If all that doesn’t help we might have to forward the issue to Particle, but try the above first.

Sorry for your inconveniences.

Ok, I will try on another PC and another USB cable. I will keep you informed!

1 Like

@ScruffR Hey I tried with another PC, new USB cable, first step being to install the drivers. It says the Photon should be in listening mode, but I’m not able to put in listening mode (by holding the setup button). I was able to do that before it all started going wrong. The photon, as before, seems to be trying to connect to the PC every 10 seconds or so (while breathing white), and the Device Manager updates at this time.

Also, I was still not able to go in safe mode (same behaviour as in the video previously sent).

Finally, the device wasn’t listed in the “Other devices” section:

What do I do at this point?

Thanks for your help!

Any luck with zadig yet?
And dfu-util?

Ok will try that!

@ScruffR Results of using zadig with libusbK

Here’s the error log:

Using inf name: Unknown_Device.inf
Successfully extracted driver files.
Installing driver. Please wait...
Driver Installation: FAILED (Resource already exists)
6 devices found.

I then tried particle flash --usb thinker, but it still failed with the same error as previous. Dfu-util is well installed, but it doesn’t detect any DFU devices.

Obviously your Photon’s USB ID is not correct/recognized.
Have you put the Photon into DFU mode?

When you perform Options - List All Devices are you seeing any other devices in the drop down?
What happens when you try to enter the correct ID?

Yes it was in DFU mode (blinking yellow).

There were 6 devices in the list.

What do you mean by putting the correct ID? And how can I do such thing?

Sorry, on your sceenshot (preview) the USB ID fields seemed enabled, but when I clicked on the image it became clear they were grayed out. So no luck with this.
Could any of the other devices in your list of six be a Photon?

If not, I guess your bootloader or some other normally untouched system area got damaged.
Have you got a Particle Programmer Shield or a JTAG programmer?
And experience in using them? If not, maybe @BDub can help?

Without these hardware tools you could open a support ticket or send a mail to hello(at) where you reference this thread.

@ScruffR No I dont have such device. And no, the photon wasnt part of the list, but it seemed cleared to me that the Photon was the unknown device.

I guess I’ll soon open a ticket. Thanks a lot for your help!

@jonathanGB, I find Windows to be a pain in the butt with devices sometimes. I regularly have issues with drivers (serial & zadig) with my devices, especially when I plug them in different ports. So, on a regular basis, I go into device manager and “purge” all my Particle devices:

  1. Unplug all my USB connected Particle devices (I have Cores, Photons, Electrons)
  2. Follow this guide to expose all hidden devices in Device Manager
  3. Go to Ports(COM & LPT) and uninstall any COM port associated with a Particle device. You can also delete the associated driver.
  4. You can also look for other libusbk devices you may have defined with Zadig
  5. Reboot your PC and reconnect your Particle device via USB.
  6. Put the device in LISTEN mode (which activates its serial mode) and install the latest serial device driver for the Particle device.
  7. Reset the Particle Device and put it in DFU mode. Then start Zadig 2.1.2 (latest), show all devices and install the correct Zadig driver for your version of windows (libusbK or WinUBS(

Now proceed with testing as before. Hopefully this resolves your problem.


Yes, that’s basically what I did when I tried with another computer which port never encountered a particle device.

Also, as stated previously, I can’t go in listening or safe mode since the problem appeared.

Thanks a lot though!

@jonathanGB, as Elites we read so many postings we sometimes get mixed up! I believe you may be at the point that you either get a JTAG programmer (eg. the Particle Programmer Shield) or get a support ticket to exchange the device. If you expect to work a lot with Particle devices, it may be worth investing in a Programmer Shield for debugging and recovery of your devices in the future. :wink:

I really appreciate your support @ScruffR and @peekay123 . I will definitely look into this programmer shield. Can it be used with Arduinos or is it only for Particle devices?

1 Like

@jonathanGB, good question! @BDub any guidance on using the Programmer Shield as a JTAG programmer for Arduino?

did you try setting up the serial/dfu tools with
this tutorial: [Particle Official] Windows 10 Full CLI and DFU Setup