Photon safe & DFU mode seems isn't working


#1

Hello guys,
I tried a to flash a photon with a testing code and after flashed the first thing I noticed is it wasn’t connected to wifi and the RGB led went off , I tried safe mode pressing setup and reset , after release reset button it flash quick in magenta but if I release setup led goes off, so i decide to try the DFU mode , so when photon led is DFU mode i tried to run particle flash --usb tinker and it responded flash success! after reset the photon rgb led still is off, I only see D7 led flashing , it look like it still have the previous firmware that caused the problem…
I tried to compile different firmware version and tried to flash those via DFU but I am getting the same result…
Any help appreciated


#2

Since this seems to be some kind of “limbo state” it might be good to do a particle update (using CLI 1.29.0) with a subsequent reflash of the bootloader.
For that download the bootloader binary from here
https://github.com/particle-iot/firmware/releases/download/v0.7.0/bootloader-0.7.0-photon.bin
and flash in Listening Mode via

particle flash --serial bootloader-0.7.0-photon.bin

It would also be good to know what kind of code you tried to flash and what was on the device before.


#3

Hello @ScruffR, I tried that but serial mode do not work .
image
what it look it work was run “particle update” when DFU mode… now its back to life :slight_smile: I will try to recreate the problem again to see what happened…
Thanks you


#4

What version Windows are you running?
Pre Win10 you may need to install drivers.


#5

Windows 10.
I had the drivers installed .


#6

With Windows 10 you should not install the Particle Serial drivers but use native Windows drivers.
Also check in Device Manager whether the device gets recognised at all as COM port.