About flashing again the firmware

Hello Group,

I am having a problem again flashing the photon . I am using linux Ubuntu 14 , I am sending you what I get in the terminal .

I put the photon in dfu mode (flashing yellow) and then I give the following commands

ioannis@ioannis-Inspiron-5547:~$ particle serial list
Found 1 device connected via serial:
/dev/ttyACM0 - Photon
ioannis@ioannis-Inspiron-5547:~$ particle flash --usb firmware.bin
Apparently I didn’t find a DFU device? util said dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to http://sourceforge.net/p/dfu-util/tickets/

Error writing firmware…no dfu device found.

Can you please help me on this because I now have 3 photons not working and want to flash them again.

Thank you

Now I get this following message

ioannis@ioannis-Inspiron-5547:~$ sudo particle flash --usb firmware.bin
Found DFU device 2b04:d006

Error writing firmware…no known App found.

Have you got a firmware.bin in that very location you’re running the command from?

Try sudo particle flash --usb tinker

1 Like

can you please give me the link to downloaded again?

I tried this and this is the result

ioannis@ioannis-Inspiron-5547:~$ sudo particle flash – usb tinker
[sudo] password for ioannis:
I couldn’t find that: usb
Potentially unhandled rejection [1] undefined (WARNING: non-Error used)
ioannis@ioannis-Inspiron-5547:~$

There is no blank in --usb!

OK done it but still flashs yellow and what ever button I push still flashs yellow

ioannis@ioannis-Inspiron-5547:~$ sudo particle flash --usb tinker
Found DFU device 2b04:d006
running dfu-util -d 2b04:d006 -a 0 -i 0 -s 0x080A0000:leave -D /usr/local/lib/node_modules/particle-cli/binaries/photon_tinker.bin

Flash success!
ioannis@ioannis-Inspiron-5547:~$

As I’ve just seen on the other thread you’ve not managed to update the firmware correctly yet, so the command above doesn’t solve the problem.
You need to get the firmware flashed propperly first and only after that you can move on.

Since things got a bit confusing with two threads dealing with one underlying problem
Please go there, read through the whole lot first, then decide which way you want to do it and stick with the order there.
And be patient, let the update do its job, till your device goes back into a stable state (for several minutes no chanes in LED behaviour).

https://github.com/spark/firmware/releases

After the update succeeded you can retry that again

sudo particle flash --usb tinker

(that darn blank between -- and usb always gets in there when you copy-paste this line from one post to another - at least on my Windows 10 Chrome setup)

OK , I have done the following :

  1. dfu-util -d 2b04:d006 -a 0 -s 0x8020000 -D /home/ioannis/system-part1-0.4.5-photon.bin

  2. dfu-util -d 2b04:d006 -a 0 -s 0x8020000 -D /home/ioannis/system-part2-0.4.5-photon.bin

  3. sudo particle update

Worked for the 2 but for the other two did not. They go to mode that they search for a wifi. I push the setup button for 20 secs and instead of going to blue flashing , it goes off, and after some sec goes steady green

Any suggestions?

Hi @johnyrobot5

The two parts do not get flashed at the same address (0x8020000) as you wrote above. The first part goes at that address but the second part goes at 0x8060000. Was that a typo or what you really did?

Can you cut-and-paste the command from the releases page linked above?

dfu-util -d 2b04:d006 -a 0 -s 0x8020000 -D system-part1-0.4.5-photon.bin
dfu-util -d 2b04:d006 -a 0 -s 0x8060000:leave -D system-part2-0.4.5-photon.bin

Sorry that was a typo.