SOS after accidental Tinker flash?


#1

Hello all, longtime browser and owner of Particle, first time poster.

I have a Particle Photon that has been running a BLYNK application to control my automation in my home shop.

For several months over the summer, it had no power as I did not want to have some cooling fans running 24/7. In any case, I plugged it in last week, connected to the cloud and was back to using my BLYNK application with no problems.

I accidentally flashed Tinker (several days ago) to it through my Adroid App and ever since that, everything has gone down hill. I’m not sure exactly what went wrong, I think my firmware got upgraded to V1.4.0 (not sure what it was before) and wiped out the previous information for BLYNK (as it shows disconnected in the Blynk App)

However, the Particle App on my Android shows that the Photon is breathing Cyan and I can send the “rainbow” Signal Device and the LED changes. PLEASE NOTE that the Particle Photon is still in the BOB in the shop and everything is OTA.

When I try to reflash Photon with the previous good working code for the BLYNK App, (which was working fine last week) the online IDE tells me it was successful, that it’s updating and that it was a success. However, none of the data makes sense in the console. The previous firmware that was loaded onto the Photon would simply provide me with Temperature and Humidity readings ONLY. Now when I flash the old code after the accidental Tinker flash, I get these readings from the console (flashing back to the old code).

The Photon also then changes from breathing Cyan to some RED SOS flashing, I have not made out the number of blinks. It has become completely uncontrollable from the BLYNK App and based on the Console feedback, something is wrong.

When I set the Photon into safemode, I can reflash Tinker but as soon as I try to change the pin in the App, the Photon faults and blinks RED. I put back into safemode, reflash the firmware working with BLYNK and the console spits out the above console information and the board faults with RED flashing. Again, it only displayed Humidity and Temperature readings and nothing in the old code changed, ever!

Regards,

-Jason


PietteTech_DHT causing SOS 14 flashes on v1.2.1-rc.3
#2

Just a guess, but are you using PietteTech_DHT library?
A while ago a potential risk for memory leaks was “fixed” in a device OS update which broke the library causing it to throw an SOS+14 error (when mentioning SOS flashing you should also state the number of slow blinks following it).

There is a PR for a workaround tho’

I’m not merging it (yet?) since I’m waiting for this bug to be addressed in the device OS


#3

Thanks for the reply, yes, I am using that Library.

Is it possible to revert to an older stable version, down from the 1.4.0 where I don’t need to change the library or code around?

Regards,

-Jason


#4

Yes, you can.
You’d need to download the device OS binaries from the device OS repo and then flash them via particle flash --usb <part2> before particle flash --usb <part1>


#5

I guess I will go down to maybe 7.0 ? I don’t remember my “working” O.S. but I will reflash in the CLI.

Regards,

-Jason


#6

The device OS issue report states this

The library has no issues on v1.1.0-rc.2, nor with versions prior to that.

So 1.0.0 should be safe and 1.1.0 would be worth a try too.


#7

I will try one (1), say 1.0.0 and if it works, I’m moving on!

Regards,

-Jason


#8

What a night of debugging.

Of all the simple things, I could not get CLI to work! I had CLI installed but it’s been some time since I used it so I opted to remove anything I had and go with a new, fresh Windows CLI install.

The CLI was the most frustrating and cumbersome part. I would search for “Particle Setup” to run the command prompt CLI and it open with a “Particle” Logo and asked me if I would like to continue with the account that I was signed into. Long story short, if I answered any of the questions with “N” the terminal would close. The point is, I could never downgrade the OS because the CLI was prompting me about the account, searching for WIFI (Which I was already setup and connected) so I kept restarting, restarting, restarting and after almost 45 minutes, I gave up. I couldn’t type in any other command…well, I could… but I wouldn’t be answering the question and the terminal would close.

So, I finally decided to try and download the workbench and thought maybe I can get the firmware done through there…I was a bit overwhelmed with everything in the application but I found the integrated CLI (which was the point in the workbench download). I started to flash the Photon, starting with Part 2 and Part 1; both showed a success! See the screenshot below (I accidentally typed the wrong “file name” for the firmware files at first, but it was corrected.)

I power cycled the unit, refreshed the web IDE and clicked on my devices only to see that OS 1.4.0 is still showing. I checked the Particle App on my Android and the OS still shows 1.4.0…

More weird stuff. While doing all this debugging, I had removed the Photon from the garage and brought into my office hooked up via USB. Everything I wrote above was done at the desk, connected via USB. The Photon was back to breathing Cyan and I actually got it communicating with the Blynk App as I was able to turn on my D7 LED that I use as a test through the Blynk App I created. I went back into the garage and plugged the unit back into the breadboard and almost immediately it started to fault RED with SOS. I mean it worked in the office, so I wanted to check if it was going to read the temperature and humidity settings but it would continue the SOS and did not connect back to the cloud.

I brought it back into my office, plugged it and breathing cyan. I was able to get it to fault and SOS if I touched it? I tried it a couple of times and it was sporadic, sometimes it would fault and SOS but it actually seemed more stable and “usable” once it was plugged in via USB in my office.

The board I made in the garage is simply a breakout board with the exception that power is being delivered to the Photon through VIN pins @ 5 VDC and NO USB connection. It’s been several months since I checked the incoming voltage, but now I am thinking it may be a power issue if it starts to fault almost immediately when plugged into my BOB, though it’s not the whole picture.

Here is a one (1) minute video of me touching the board when it faults. It’s hard to determine if I caused this or if it is random and just happens by coincidence while debugging in my office and connected via the USB.

https://www.youtube.com/watch?v=4-ZtYHKfVA4&feature=youtu.be

My open issues:

  1. I downgraded the firmware through the Workbench but the Photon still shows OS 1.4.0.
  2. I seem to have better results now with the USB, but still faults (possible random or induced)
  3. My real setup in the garage for some reason, faults the Photon almost immediately and perhaps is related to a power issue?

Regards,

-Jason


#9

Where in WB does it show that?
What does particle identify and particle serial inspect give you?
Before downgrading the device OS you need to make sure your application firmware (which is not replaced when downgrading) does not cause an immediate upgrade again due to its target version.

Are all your SOS panics you are reporting above always SOS+14 or are you seeing other codes too?

You are talking about a Photon but your screenshot shows system-part2-0.7.0-p1.bin and system-part1-0.7.0-p1.bin which are not compatible with the Photon. P1 is not the same as Photon.


#10

Hi ScruffR,

The OS is showing on my android app and when I am in the online account and looking at my devices, not the workbench. I only used the workbench to gain access to the integrated CLI.

I will need to check **particle identify and particle serial inspect

Hmmm, I have no idea if my application firmware is causing an immediate update…any tips on where to look for this?

I’m not sure if the SOS has changed or not, but the video link is pretty much what I experience since the start of my issues.

Uh oh…I definitely was trying to load p1 thinking it was Photon…no wonder why the device still reads OS 1.4.0.


#11

particle serial inspect would show.
But to be on the safe side you can do particle flash --usb tinker to install a firmware that is definetly targeted at a really old device OS and hence won’t cause an auto-update.


#12

Boy did I do great things yesterday…

I’ll start this post by saying I bricked my Photon. I was updating the Photon through the Workbench CLI which I either had to be breathing Cyan or in safe mode. DFU (yellow blinking) did not work as the workbench CLI would “time out”. I put the Photon into Safe Mode ( Magenta) started the Part2 update first, success. I started the last Part1, lost my train of thought for a couple of minutes not paying attention and accidentally unplugged my Photon during the 2nd process, bricked my Photon afterwards. No power, no LEDs (except very dim D7).

I was just about to walk away since I had both my Photons breathing…but no, I had to try and downgrade the OS and instead bricked my first Photon.

For some reason, my second Photon would “time out” when I tried to downgrade in the workbench CLI. Also, I just claimed this Photon the other night, the OS version I believe was 0.5.5 (I think)…I check my devices tab and the OS for this new Photon was upgraded to the OS 1.4.0.

Back to square one trying to downgrade a second Photon all while I bricked and ruined my beloved first Photon which had my duck antenna installed…will try and salvage that.

More updates coming…I hate destroying hardware.


#13

I am able to flash this:

PS C:\Users\Jason\Documents\IoT\Photon\FIRMWARE> particle flash Photon-2 system-part2-0.7.0-photon.bin
Including:
system-part2-0.7.0-photon.bin
attempting to flash firmware to your device Photon-2
Flash device OK: Update started

Flash success!

PS C:\Users\Jason\Documents\IoT\Photon\FIRMWARE> particle flash Photon-1 system-part1-0.7.0-photon.bin
Including:
system-part1-0.7.0-photon.bin
attempting to flash firmware to your device Photon-1
Flash device failed: Timed out.

Everything is giving me an issue. Both Photons (now one being dead) act the same on OS 1.4.0.

So the Photon I am working on (the 2nd one) now does what the first Photon did. It seems to work better with the USB, connects and breaths and I have control (just D7 LED as test) but it will fault RED if I touch the board. It almost immediately faults when I plug into my customer BOB. Which by the way, worked since November and the voltages are spot on so it’s not the VDC.

Also, why doesn’t the CLI in Workbench accept ’ $ ’ in the powershell terminal?

New video coming soon.

-Jason


#14

See link for Photon faulting almost immediately when installed in my custom BOB. Voltages are perfect at 5.01 VDC on VIN and am no longer convinced it was a voltage issue. This Photon auto updated to 1.4.0 OS and for whatever reason, operates differently when in my BOB or when connected via USB. It’s more sensitive now in the BOB and again, faults immediately. If it does breath cyan, it connects with Blynk and also pings rainbow with Android App; but again via USB power.

Cheers.

Jason


#15

This is a long shot, but can you measure the Vin Voltage when the Photon is Starting, while installed in your BOB ?


#16

It may be best to get USB flashing to work properly before moving on as it makes up-/downgrading much simpler and reliable.


#17

I will check the startup up VIN later today. I only checked the VIN when it was turned on, not the “start up” moment.

Some of the things are bothering me.

The Windows CLI doesn’t work for me, it asks me questions about setting up my Particle but crashes whenever I select NO. I can never type in a command because of the prompts on account set-up, wifi etc…

Because it was crashing, I went to the workbench powershell but the last few nights proved that I can’t downgrade the last final part (part 1) through the terminal as it times out and no other commands are recognized.


#18

Saturday Morning - 8:00 AM 09-28-2019

After a nights sleep from Friday night debugging, back into the Workbench we go.

I just downgraded to OS 0.7.0 :grinning:

I’m about to flash the actual application that seems to be part of the problem (hopefully not on OS 0.7.0), I even have System.disableUpdates(); in my application code to prevent an automatic updates (at least I hope that’s what I’m doing).

However, the big milestone here is the downgrade itself because I have been trying to downgrade all week.

  1. I’m inside the Workbench.
  2. I am using the Particle CLI within workbench.
  3. After downloading the right downgrade bin files, i’ll flash them using:
    PS C:\Users\Jason\Documents\IoT\Photon\FIRMWARE> particle flash Photon-2 system-part2-0.7.0-photon.bin
    Including:
    system-part2-0.7.0-photon.bin
    attempting to flash firmware to your device Photon-2
    Flash device OK: Update started

Flash success!

PS C:\Users\Jason\Documents\IoT\Photon\FIRMWARE> particle flash Photon-2 system-part1-0.7.0-photon.bin
Including:
system-part1-0.7.0-photon.bin
attempting to flash firmware to your device Photon-2
Flash device OK: Update started

Flash success!


SUCCESS_2

  1. Check my device panel (system shows 0.7.0)

NOTE: This post is real time, I am viewing my console and downgrading has shown the changes taking place in the “Particle Console” which is online. I guess to use the features, you need to have a higher OS system as it’s prompting updates.

Thoughts before I attempt to flash the App file which might break and ruin this OS downgrade milestone.

  1. I wasn’t in blinking yellow mode (DFU) (It would time out in CLI)
  2. I was in breathing cyan mode when I downgraded
  3. I tried both ways using the command prompt/Workbench Particle CLI
  4. I repeated several times the code above for downgrade and would “time out”
  5. I’m not sure why this didn’t work the past few days.

#19

Yes!!! Application flashed to Photon with OS 0.7.0 and the readings are coming back as I remember since nothing really changed other than a bad 1.4.0 OS with my Application.

Please note, the sensors are not hooked up at the moment since the debugging is happening at my desk.

But the proof is below, the humidity and temperature is what has not been displaying.

SUCCESS_4

The other big question will be is what happens when I go plug this into my custom BOB in the shop?

Lets go find out.

-Jason


#20

Happy to report that downgrading to OS 0.7.0 has solved everything.

I flashed my application and we are back! No more faults when I plug the Photon back in the shop break out board. Check out the Blynk app showing the temperature and humidity again as well as controlling my pins.

Just annoyed my original Photon got bricked because of this.