Can't Flash Firmware

Hello,

I just recently bought ANOTHER Photon because I fried my last one after a couple months of use and the first never worked to begin with. My issue that I’m having is that I can connect my device to my account and can even signal the LED to flash different colors using the “signal” button, but I can’t flash any firmware because it times out every single time. I’ve tried putting it in safe and DFU mode with no luck. I’m hoping that someone has had a similar issue and could help me solve this problem.

Thanks,

Nick

What tool are you using to perform the flash? Web IDE, CLI, Particle Dev.

1 Like

I’ve now tried Wed IDE (at least 50 times) AND CLI

Is the device in safe mode and did you select it (:star:) under the devices tab?

1 Like

How do I determine if it is in Safe Mode (it’s currently breathing cyan). And I don’t see the star option under the devices tab. I only have this one device and that is all that’s showing up.

Mouse over the area on the left of the device name and click on it. You should see a :star: appear.

1 Like

I am using a Photon if that makes a difference. Attached is how my device list looks. Thank you for you help by the way.

I really do believe that there is some simple error that I’m missing because the signal button works just fine.

There’s no difference. The issue is that you are not selecting it as the device to be flashed.

Notice that there is a :star: on my selected device.

1 Like

There is no option for me to star the selected device in the webpage. Clicking on the name allows my to change the name and clicking anywhere else besides the arrow does nothing else.

I know that its trying to flash to the device because I see this while trying to flash.

Can you refresh the Web IDE and try again?

What is the error message?

1 Like

I refreshed and tried again. I tried the Blink code multiple times. Every time it said “Flashing Code…” then “Taking longer than usual…” and most of the times it will time out and others it will say that the flash was successful but it obviously isn’t because the code didn’t function.

@suda can you take a look?
@buchnich can you PM me your device id?

Also, can you place the device in Safe mode (breathing magenta to be sure it’s not user firmware issue)?

1 Like

Noob question here but…how do I PM you? I can’t find the button. And I will put the device in Safe Mode right now.

I ran into this issue earlier, but I can’t get the device to enter safe mode. I hold down both buttons, release the reset button, wait for it to flash magenta, and then release the setup button, but it goes straight to flashing blue.

Weird. Is it a new device or have you been using it for a while now?

Do you also have CLI installed?

1 Like

It is a new device, and I have been using a Photon for a few months now so I know my way around them. I have CLI installed.

Can you place the device in DFU mode and do a particle update and particle flash --usb tinker then see if the device can be place in Safe mode?

2 Likes

Those things are a bit inconsistent. Try being as accurate as possible when describing your issues, since it’s hard for us to guess what you’re doing from halfway around the globe.

What exactly have you tried in the CLI? Could you show us the commands and output?

Hover to the left of the device, in the same place as @kennethlimcp’s images, and you should see a grayed out star pop up.

Click our profile pictures.

That’s actual pure blue, not cyan, right?

Make sure it’s up-to-date before issues the commands suggested by Kenneth. npm install -g particle-cli should take care of that.