Can't Flash Firmware

That might not apply to accounts with only one device, but if it’s the only device that’s the one Web IDE will be targeting.

If you already have CLI installed, the update command would be

npm update -g particle-cli

@buchnich did you managed to resolve the issue? Otherwise, do PM me your device id.

Thanks! :wink:

1 Like

Sorry, I’ve been trying to tell you that I’ve fixed the issue, but I’ve reached my daily limit for posts! I fixed it once I figure out to install Homebrew on my Mac. /thread

1 Like

What was the fix?

You should be able to post more regularly now :wink:

1 Like

Since I couldn’t get Homebrew to install via the instructions on its website, I found this script that automatically installed Homebrew (and a number of random web dev tools). Once I had it installed I could finally use the ‘brew’ command in Terminal to flash the Tinker firmware to the Photon.

Thanks for the help!

Are you able to get into safe mode now?

Does that mean your user firmware is causing the OTA to fail?

The browser tells me that I’m in Safe Mode but when I tried to do it the light flashed green, not magenta. Whatever the reason, I’m able to flash code now. I don’t believe the code I was flashing or am flashing now caused the issue.

Ok can you still PM me your device ID to check the logs and make sure nothing weird happened?

Thanks!